<!DOCTYPE html><html lang="en-US" prefix="og: https://ogp.me/ns#" class="no-js no-svg"><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name="viewport" content="user-scalable=yes, width=device-width, initial-scale=1.0, maximum-scale=1, minimum-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11" /> <meta name="author" content="Rodger H. Hosking"> <title>Choosing Real-Time Embedded System Products | Circuit Cellar</title>   <meta property="og:title" content="Choosing Real-Time Embedded System Products" /><meta property="og:description" content="10 Key Tips ByRodger Hosking,V.P. and Co-Founder of Pentek There are many factors to consider when selecting components and board-level solutions for a re" /><meta property="og:url" content="https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/" /><meta property="og:image" content="https://circuitcellar.com/wp-content/uploads/2020/04/Hoskings-354-lead.png" />  <meta name="twitter:card" content="summary"><meta name="twitter:title" content="Choosing Real-Time Embedded System Products" /><meta name="twitter:description" content="10 Key Tips ByRodger Hosking,V.P. and Co-Founder of Pentek There are many factors to consider when selecting components and board-level solutions for a re" /><meta name="twitter:image" content="https://circuitcellar.com/wp-content/uploads/2020/04/Hoskings-354-lead.png" /> <meta name="author" content="Rodger H. Hosking" /> <meta name="description" content="What are the top 10 factors to consider when selecting components and board-level solutions for a real-time embedded system? Rodger steps through 10 key tips." /><meta name="keywords" content="openvpx,vpx,embedded boards,fpgas,5g,wireless,xmc,,design solutions,research &amp; design hub" /> <script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://circuitcellar.com/#organization","url":"https://circuitcellar.com/","name":"Circuit Cellar","sameAs":[]},{"@type":"WebSite","@id":"https://circuitcellar.com/#website","url":"https://circuitcellar.com/","name":"Circuit Cellar","publisher":{"@id":"https://circuitcellar.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://circuitcellar.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/#webpage","url":"https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/","inLanguage":"en-US","name":"Choosing Real-Time Embedded System Products","isPartOf":{"@id":"https://circuitcellar.com/#website"},"breadcrumb":{"@id":"https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/#breadcrumblist"},"description":"What are the top 10 factors to consider when selecting components and board-level solutions for a real-time embedded system? Rodger steps through 10 key tips.","image":{"@type":"ImageObject","@id":"https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/#primaryimage","url":"https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/Hoskings-354-lead.png?fit=1243%2C785&ssl=1","width":1243,"height":785},"primaryImageOfPage":{"@id":"https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/#primaryimage"},"datePublished":"2020-05-06T23:05:39-04:00","dateModified":"2020-05-07T14:33:56-04:00"},{"@type":"Article","@id":"https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/#article","isPartOf":{"@id":"https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/#webpage"},"author":{"@id":"https://circuitcellar.com/author/rodger-h-hosking/#author"},"headline":"Choosing Real-Time Embedded System Products","datePublished":"2020-05-06T23:05:39-04:00","dateModified":"2020-05-07T14:33:56-04:00","commentCount":0,"mainEntityOfPage":{"@id":"https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/#webpage"},"publisher":{"@id":"https://circuitcellar.com/#organization"},"articleSection":"Design Solutions, Research &amp; Design Hub, 5G, embedded boards, FPGAs, OpenVPX, VPX, wireless, XMC","image":{"@type":"ImageObject","@id":"https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/#primaryimage","url":"https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/Hoskings-354-lead.png?fit=1243%2C785&ssl=1","width":1243,"height":785}},{"@type":"Person","@id":"https://circuitcellar.com/author/rodger-h-hosking/#author","name":"Rodger H. Hosking","sameAs":[]},{"@type":"BreadcrumbList","@id":"https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://circuitcellar.com/","url":"https://circuitcellar.com/","name":"Circuit Cellar | Microcontrollers, Embedded Systems, &amp; Electrical Engineering Information "}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/","url":"https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/","name":"Choosing Real-Time Embedded System Products"}}]}]}</script> <link rel="canonical" href="https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/" /> <script type="text/javascript">window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
				ga('create', 'UA-12942761-3', 'auto');
				// Plugins
				ga('require', 'outboundLinkTracker');
				ga('send', 'pageview');</script> <link rel="stylesheet" type="text/css" href="https://circuitcellar.com/wp-content/plugins/nextend-smart-slider3-pro/Public/SmartSlider3/Application/Frontend/Assets/dist/smartslider.min.css?ver=70fceec4" media="all" /><style type="text/css">.n2-ss-spinner-simple-white-container {
    position: absolute;
    top: 50%;
    left: 50%;
    margin: -20px;
    background: #fff;
    width: 20px;
    height: 20px;
    padding: 10px;
    border-radius: 50%;
    z-index: 1000;
}

.n2-ss-spinner-simple-white {
  outline: 1px solid RGBA(0,0,0,0);
  width:100%;
  height: 100%;
}

.n2-ss-spinner-simple-white:before {
    position: absolute;
    top: 50%;
    left: 50%;
    width: 20px;
    height: 20px;
    margin-top: -11px;
    margin-left: -11px;
}

.n2-ss-spinner-simple-white:not(:required):before {
    content: '';
    border-radius: 50%;
    border-top: 2px solid #333;
    border-right: 2px solid transparent;
    animation: n2SimpleWhite .6s linear infinite;
}
@keyframes n2SimpleWhite {
    to {transform: rotate(360deg);}
}</style><script async src="https://www.google-analytics.com/analytics.js"></script> <script async src="https://circuitcellar.com/wp-content/plugins/all-in-one-seo-pack/public/js/vendor/autotrack.js?ver=3.6.2"></script> <link rel='dns-prefetch' href='//www.google.com' /><link rel='dns-prefetch' href='//js.stripe.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Circuit Cellar &raquo; Feed" href="https://circuitcellar.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Circuit Cellar &raquo; Comments Feed" href="https://circuitcellar.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Circuit Cellar &raquo; Choosing Real-Time Embedded System Products Comments Feed" href="https://circuitcellar.com/research-design-hub/choosing-real-time-embedded-system-products/feed/" /><link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.4.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style><link rel='stylesheet' id='BNSFC-Style-css' href='https://circuitcellar.com/wp-content/plugins/bns-featured-category/bnsfc-style.css' type='text/css' media='screen' /><link rel='stylesheet' id='ctct_form_styles-css' href='https://circuitcellar.com/wp-content/plugins/constant-contact-forms/assets/css/style.css' type='text/css' media='all' /><link rel='stylesheet' id='cookie-law-info-css' href='https://circuitcellar.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-public.css' type='text/css' media='all' /><link rel='stylesheet' id='cookie-law-info-gdpr-css' href='https://circuitcellar.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-gdpr.css' type='text/css' media='all' /><link rel='stylesheet' id='mks_shortcodes_simple_line_icons-css' href='https://circuitcellar.com/wp-content/plugins/meks-flexible-shortcodes/css/simple-line/simple-line-icons.css' type='text/css' media='screen' /><link rel='stylesheet' id='mks_shortcodes_css-css' href='https://circuitcellar.com/wp-content/plugins/meks-flexible-shortcodes/css/style.css' type='text/css' media='screen' /><link rel='stylesheet' id='molongui-authorship-css' href='https://circuitcellar.com/wp-content/plugins/molongui-authorship-pro/public/css/molongui-authorship-pro.1026.min.css' type='text/css' media='all' /><link rel='stylesheet' id='issuem-leaky-paywall-css' href='https://circuitcellar.com/wp-content/plugins/leaky-paywall//css/issuem-leaky-paywall.css' type='text/css' media='all' /><link rel='stylesheet' id='leaky-paywall-article-countdown-nag-css' href='https://circuitcellar.com/wp-content/plugins/leaky-paywall-article-countdown-nag/css/article-countdown-nag-slim.css' type='text/css' media='all' /><link rel='stylesheet' id='leaky-paywall-coupons-css-css' href='https://circuitcellar.com/wp-content/plugins/leaky-paywall-coupons//css/leaky-paywall-coupons.css' type='text/css' media='all' /><link rel='stylesheet' id='vce-fonts-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%7CRoboto+Slab%3A400&#038;subset=latin%2Clatin-ext&#038;ver=2.9.2' type='text/css' media='all' /><link rel='stylesheet' id='vce-style-css' href='https://circuitcellar.com/wp-content/themes/voice/assets/css/min.css' type='text/css' media='all' /><style id='vce-style-inline-css' type='text/css'>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</style><link rel='stylesheet' id='meks-social-widget-css' href='https://circuitcellar.com/wp-content/plugins/meks-smart-social-widget/css/style.css' type='text/css' media='all' /><link rel='stylesheet' id='meks_ess-main-css' href='https://circuitcellar.com/wp-content/plugins/meks-easy-social-share/assets/css/main.css' type='text/css' media='all' /><link rel='stylesheet' id='ss-style-css' href='https://circuitcellar.com/wp-content/plugins/simple-sponsorships-premium/assets/dist/css/premium/public.css' type='text/css' media='all' /><style id='kadence-blocks-heading-inline-css' type='text/css'>.wp-block-kadence-advancedheading mark{color:#f76a0c;background:transparent;border-style:solid;border-width:0}</style><link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.7.1/css/jetpack.css' type='text/css' media='all' /> <script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery-migrate.min.js'></script> <script type='text/javascript'>/* <![CDATA[ */
var Cli_Data = {"nn_cookie_ids":[],"cookielist":[]};
var log_object = {"ajax_url":"https:\/\/circuitcellar.com\/wp-admin\/admin-ajax.php"};
/* ]]> */</script> <script type='text/javascript' src='https://circuitcellar.com/wp-content/plugins/cookie-law-info/public/js/cookie-law-info-public.js'></script> <script type='text/javascript' src='https://js.stripe.com/v3/?ver=5.4.2'></script> <script type='text/javascript'>/* <![CDATA[ */
var lp_registration_redirect_ajax = {"ajaxurl":"\/wp-admin\/admin-ajax.php"};
/* ]]> */</script> <script type='text/javascript' src='https://circuitcellar.com/wp-content/plugins/leaky-paywall-registration-redirect/js/leaky-paywall-registration-redirect.js'></script> <script type='text/javascript'>/* <![CDATA[ */
var lp_acn = {"ajaxurl":"https:\/\/circuitcellar.com\/wp-admin\/admin-ajax.php"};
/* ]]> */</script> <script type='text/javascript' src='https://circuitcellar.com/wp-content/plugins/leaky-paywall-article-countdown-nag/js/article-countdown-nag.js'></script> <script type='text/javascript' src='https://circuitcellar.com/wp-content/plugins/leaky-paywall-coupons/js/leaky-paywall-coupons.js'></script> <link rel='https://api.w.org/' href='https://circuitcellar.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://circuitcellar.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://circuitcellar.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Carrier Boards Support Jetson Nano Modules' href='https://circuitcellar.com/tech-news/product-news/carrier-boards-support-jetson-nano-modules/' /><link rel='next' title='600W Fanless AC-DC Supplies Target Medical' href='https://circuitcellar.com/tech-news/product-news/600w-fanless-ac-dc-supplies-target-medical/' /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://circuitcellar.com/?p=249311' /><link rel="alternate" type="application/json+oembed" href="https://circuitcellar.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcircuitcellar.com%2Fresearch-design-hub%2Fchoosing-real-time-embedded-system-products%2F" /><link rel="alternate" type="text/xml+oembed" href="https://circuitcellar.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcircuitcellar.com%2Fresearch-design-hub%2Fchoosing-real-time-embedded-system-products%2F&#038;format=xml" /> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4310582701436176",
    enable_page_level_ads: true
  });</script>  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-12942761-3"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-12942761-3');</script> <link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//i1.wp.com' /><link rel='dns-prefetch' href='//i2.wp.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><style type='text/css'>img#wpstats{display:none}</style><link rel="shortcut icon" href="https://circuitcellar.com/wp-content/uploads/2013/12/favicon-1.ico" /><style type="text/css">/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link rel="icon" href="https://i1.wp.com/circuitcellar.com/wp-content/uploads/2017/08/cropped-CC-logo_stacked_512.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i1.wp.com/circuitcellar.com/wp-content/uploads/2017/08/cropped-CC-logo_stacked_512.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i1.wp.com/circuitcellar.com/wp-content/uploads/2017/08/cropped-CC-logo_stacked_512.jpg?fit=180%2C180&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i1.wp.com/circuitcellar.com/wp-content/uploads/2017/08/cropped-CC-logo_stacked_512.jpg?fit=270%2C270&#038;ssl=1" /><style type="text/css" id="wp-custom-css">.sidebar .widget-title {
    padding: 2px;
}



.main-navigation a {
    padding: 7px 12px 7px 12px;
}

@media only screen and (max-width: 1200px) and (min-width: 1024px) {
.main-navigation a {
    padding: 9px 6px;
}
}

.widget p, .widget>div, .widget>form, .widget>ul {
    padding: 10px; 
}

a.category-5 {
display:none;
}

a.category-5 + span{
display: none;
}

.site-footer .widget-title { font-size: 15px !important;
    padding: 2px;
}

.site-footer .widget { font-size: 12px !important; line-height: 1.47; margin: 0 0 0px; }

.sidebar .widget { margin: 0 0 8px; }

.single .meta-image img {
    width: auto; max-height: 300px; text-align: center; display: block;
    margin-left: auto;
    margin-right: auto;

}

.page-id-245883 #option-0, .page-id-245883 #option-1, .page-id-245883 #option-2 { display: none; }

.page-id-243360 #option-3, .page-id-243360 #option-4, .page-id-243360 #option-5, .page-id-243360 #option-6 { display: none; }

blockquote p {
font-size: 14px; line-height: 1.67;
}

h2 {
  font-weight: bold;
   font-size: 25px;
}

h3 {
  font-weight: bold;
   font-size: 18px;
}</style> <script src="https://linuxgizmos.advertserve.com/js/libcode1_noajax.js" type="text/javascript"></script>   <script type="text/javascript">var _avp = _avp || [];
(function() {
  var s = document.createElement('script');
  s.type = 'text/javascript'; s.async = true; s.src = window.location.protocol + '//linuxgizmos.advertserve.com/js/libcode3.js';
  var x = document.getElementsByTagName('script')[0];
  x.parentNode.insertBefore(s, x);
})();</script>  <script type="text/javascript">(function(){var N=this;N.N2_=N.N2_||{r:[],d:[]},N.N2R=N.N2R||function(){N.N2_.r.push(arguments)},N.N2D=N.N2D||function(){N.N2_.d.push(arguments)}}).call(window);if(!window.n2jQuery){window.n2jQuery={ready:function(cb){console.error('n2jQuery will be deprecated!');N2R(['$'],cb)}}}window.nextend={localization:{},ready:function(cb){console.error('nextend.ready will be deprecated!');N2R('documentReady',function($){cb.call(window,$)})}};</script><script type="text/javascript" src="https://circuitcellar.com/wp-content/plugins/nextend-smart-slider3-pro/Public/SmartSlider3/Application/Frontend/Assets/dist/n2-j.min.js?ver=70fceec4"></script> <script type="text/javascript" src="https://circuitcellar.com/wp-content/plugins/nextend-smart-slider3-pro/Public/SmartSlider3/Application/Frontend/Assets/dist/nextend-gsap.min.js?ver=70fceec4"></script> <script type="text/javascript" src="https://circuitcellar.com/wp-content/plugins/nextend-smart-slider3-pro/Public/SmartSlider3/Application/Frontend/Assets/dist/smartslider-frontend.min.js?ver=70fceec4"></script> <script type="text/javascript" src="https://circuitcellar.com/wp-content/plugins/nextend-smart-slider3-pro/Public/SmartSlider3Pro/Slider/SliderType/Carousel/Assets/dist/smartslider-carousel-type-frontend.min.js?ver=70fceec4"></script> <script type="text/javascript">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</script></head><body data-rsssl=1 class="post-template-default single single-post postid-249311 single-format-standard wp-embed-responsive ctct-voice vce-sid-right voice-v_2_9_2"><div id="vce-main"><header id="header" class="main-header"><div class="top-header"><div class="container"><div class="vce-wrap-left"><ul id="vce_top_navigation_menu" class="top-nav-menu"><li id="menu-item-243649" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-243649"><a href="https://circuitcellar.com/member-sign-in/">LOG IN</a></li><li id="menu-item-243658" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-243658"><a href="https://circuitcellar.com/membership-options/">REGISTER</a></li><li id="menu-item-243929" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-243929"><a href="https://circuitcellar.com/about-us/">About Us  </a><ul class="sub-menu"><li id="menu-item-243930" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-243930"><a href="https://circuitcellar.com/magazine/">About the Magazine</a></li><li id="menu-item-243931" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-243931"><a href="https://circuitcellar.com/how-it-all-began/">How it all began</a></li><li id="menu-item-243932" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-243932"><a href="https://circuitcellar.com/timeline-first-25-years/">Timeline – First 25 Yr</a></li><li id="menu-item-243933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-243933"><a href="/category/25th-anniversary/">25th Anniversary</a></li><li id="menu-item-243934" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-243934"><a href="https://circuitcellar.com/contact-us/">Contact Us</a></li></ul></li></ul></div><div class="vce-wrap-right"><div class="menu-social-container"><ul id="vce_social_menu" class="soc-nav-menu"><li id="menu-item-243655" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-243655"><a target="_blank" rel="noopener noreferrer" href="https://facebook.com/circuitcellar"><span class="vce-social-name">Facebook</span></a></li><li id="menu-item-243656" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-243656"><a target="_blank" rel="noopener noreferrer" href="https://www.twitter.com/circuitcellar"><span class="vce-social-name">Twitter</span></a></li><li id="menu-item-243805" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-243805"><a target="_blank" rel="noopener noreferrer" href="https://www.linkedin.com/company/circuit-cellar/"><span class="vce-social-name">Linkedin</span></a></li><li id="menu-item-243806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-243806"><a target="_blank" rel="noopener noreferrer" href="https://www.pinterest.com/CircuitCellar"><span class="vce-social-name">Pintrest</span></a></li><li id="menu-item-243807" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-243807"><a target="_blank" rel="noopener noreferrer" href="https://www.reddit.com/domain/circuitcellar.com/"><span class="vce-social-name">Reddit</span></a></li></ul></div></div><div class="vce-wrap-center"><form class="vce-search-form" action="https://circuitcellar.com/" method="get"> <input name="s" class="vce-search-input" size="20" type="text" value="Type here to search..." onfocus="(this.value == 'Type here to search...') && (this.value = '')" onblur="(this.value == '') && (this.value = 'Type here to search...')" placeholder="Type here to search..." /> <button type="submit" class="vce-search-submit"><i class="fa fa-search"></i></button></form></div></div></div><div class="container header-2-wrapper header-main-area"><div class="vce-res-nav"> <a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a></div><div class="site-branding"> <span class="site-title"><a href="https://circuitcellar.com/" rel="home" class="has-logo"><picture class="vce-logo"><source media="(min-width: 1024px)" srcset="https://circuitcellar.com/wp-content/uploads/2019/08/CC_logo.png"><source srcset="https://circuitcellar.com/wp-content/uploads/2019/08/CC_logo.png"><img src="https://circuitcellar.com/wp-content/uploads/2019/08/CC_logo.png" alt="Circuit Cellar"></picture></a></span><span class="site-description">    Inspiring the Evolution of Embedded Design.</span></div><div class="vce-header-ads">  <script type="text/javascript">document.write('<scr'+'ipt src="https://linuxgizmos.advertserve.com/servlet/view/banner/javascript/zone?zid=34&pid=3&resolution='+(window.innerWidth||screen.width)+'x'+(window.innerHeight||screen.height)+'&random='+Math.floor(89999999*Math.random()+10000000)+'&millis='+new Date().getTime()+'&referrer='+encodeURIComponent((window!=top&&window.location.ancestorOrigins)?window.location.ancestorOrigins[window.location.ancestorOrigins.length-1]:document.location)+'" type="text/javascript"></scr'+'ipt>');</script> </div></div><div class="header-bottom-wrapper header-left-nav"><div class="container"><nav id="site-navigation" class="main-navigation" role="navigation"><ul id="vce_main_navigation_menu" class="nav-menu"><li id="menu-item-114900" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-114900"><a href="https://circuitcellar.com/">Home</a><li id="menu-item-231519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-231519"><a href="#">Magazine</a><ul class="sub-menu"><li id="menu-item-230728" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-230728"><a href="https://circuitcellar.com/inside-this-issue/">Inside This Issue</a><li id="menu-item-114902" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114902"><a href="https://circuitcellar.com/subscription/">Subscribe</a><li id="menu-item-238664" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-238664"><a href="https://simplecirc.com/subscriber_login/circuit-cellar">Subscription Management</a><li id="menu-item-242332" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-242332"><a href="https://circuitcellar.com/subscription-management/">Subscription Access &#038; Help</a><li id="menu-item-114904" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-114904"><a target="_blank" rel="noopener noreferrer" href="https://drive.google.com/open?id=1xeU29a9ZSZfGGtYFe625S9jttg_Ra2Oy">Article Code &#038; Files</a><li id="menu-item-244275" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244275 vce-cat-3738"><a href="https://circuitcellar.com/category/article-materials-and-resources/">Article Materials and Resources</a><li id="menu-item-243659" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-243659"><a target="_blank" rel="noopener noreferrer" href="http://cc-webshop.com">Purchase Back Issues</a><li id="menu-item-237551" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237551"><a href="https://circuitcellar.com/editorial-calendar/">Editorial Calendar</a><li id="menu-item-114916" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114916"><a href="https://circuitcellar.com/submit/">Submit Your Technical Article</a><li id="menu-item-114908" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114908"><a href="https://circuitcellar.com/errata-corrections-updates/">Errata, Corrections, &#038; Updates</a><li id="menu-item-238728" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-238728"><a href="https://circuitcellar.com/circuit-cellar-newsletter-subscribe/">Circuit Cellar Newsletter</a><li id="menu-item-233724" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-233724"><a href="https://circuitcellar.com/collegedigitalprogram/">College Digital Subscription Program</a></ul><li id="menu-item-243841" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-243841 vce-cat-4715"><a href="https://circuitcellar.com/category/research-design-hub/">Research &#038; Design Hub</a><ul class="sub-menu"><li id="menu-item-243842" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243842 vce-cat-4720"><a href="https://circuitcellar.com/category/research-design-hub/basics-of-design/">Basics of Design</a><li id="menu-item-243843" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-243843 vce-cat-4719"><a href="https://circuitcellar.com/category/research-design-hub/design-solutions/">Design Solutions</a><li id="menu-item-243844" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243844 vce-cat-4721"><a href="https://circuitcellar.com/category/research-design-hub/projects/">Projects</a><li id="menu-item-243845" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243845 vce-cat-4722"><a href="https://circuitcellar.com/category/research-design-hub/tech-trends/">Tech Trends</a><li id="menu-item-243846" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243846 vce-cat-152"><a href="https://circuitcellar.com/category/research-design-hub/test-your-eq/">Test Your EQ (Engineering Quotient)</a></ul><li id="menu-item-243860" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-243860 vce-cat-4716"><a href="https://circuitcellar.com/category/insights/">Insights</a><ul class="sub-menu"><li id="menu-item-243861" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243861 vce-cat-23"><a href="https://circuitcellar.com/category/insights/editor-letter/">Editor&#8217;s Letter</a><li id="menu-item-243862" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243862 vce-cat-12"><a href="https://circuitcellar.com/category/insights/interviews/">Interviews</a><li id="menu-item-243863" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243863 vce-cat-332"><a href="https://circuitcellar.com/category/insights/tech-the-future/">Tech The Future</a></ul><li id="menu-item-243870" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-243870 vce-cat-1308"><a href="https://circuitcellar.com/category/tech-news/">Tech News</a><ul class="sub-menu"><li id="menu-item-243871" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243871 vce-cat-336"><a href="https://circuitcellar.com/category/tech-news/industry-profiles/">Industry Profiles</a><li id="menu-item-243872" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243872 vce-cat-82"><a href="https://circuitcellar.com/category/tech-news/product-news/">Product News</a></ul><li id="menu-item-243864" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-243864 vce-cat-1293"><a href="https://circuitcellar.com/category/resources/">Resources</a><ul class="sub-menu"><li id="menu-item-243865" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243865 vce-cat-53"><a href="https://circuitcellar.com/category/resources/crossword/">Crossword</a><li id="menu-item-243866" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243866 vce-cat-656"><a href="https://circuitcellar.com/category/resources/ee-tips/">EE Tips</a><li id="menu-item-248811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-248811 vce-cat-4952"><a href="https://circuitcellar.com/category/design-contest/">Design Contest Winning Entries</a><li id="menu-item-243867" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243867 vce-cat-219"><a href="https://circuitcellar.com/category/resources/clubs/">Clubs/Organizations</a><li id="menu-item-243868" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243868 vce-cat-271"><a href="https://circuitcellar.com/category/resources/professional-profiles/">Professional&#8217;s Profiles</a><li id="menu-item-243869" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243869 vce-cat-14"><a href="https://circuitcellar.com/category/resources/workspaces/">Workspaces</a></ul><li id="menu-item-244371" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-244371 vce-cat-4782"><a href="https://circuitcellar.com/category/directories/">Directories</a><ul class="sub-menu"><li id="menu-item-244372" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244372 vce-cat-4783"><a href="https://circuitcellar.com/category/directories/datasheet/">Datasheet</a><li id="menu-item-244373" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244373 vce-cat-4784"><a href="https://circuitcellar.com/category/directories/vendor-directory/">Vendor Directory</a></ul><li id="menu-item-245914" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-245914"><a href="https://circuitcellar.com/mediakit/">Advertise</a><ul class="sub-menu"><li id="menu-item-240411" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240411"><a href="https://circuitcellar.com/mediakit/">Circuit Cellar Media Kit</a><li id="menu-item-238743" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-238743"><a href="https://visitor.r20.constantcontact.com/d.jsp?llr=4tkwpoeab&#038;p=oi&#038;m=1104292817535&#038;sit=upajn4wfb&#038;f=74d1a91d-9040-4a12-928d-dfaa6af2a8e7">Sign up for the Advertiser Notification Broadcast</a><li id="menu-item-114928" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114928"><a href="https://circuitcellar.com/editorial-calendar/">Editorial Calendar</a></ul></ul></nav></div></div></header><div id="sticky_header" class="header-sticky"><div class="container"><div class="vce-res-nav"> <a class="vce-responsive-nav" href="#sidr-main"><i class="fa fa-bars"></i></a></div><div class="site-branding"> <span class="site-title"><a href="https://circuitcellar.com/" rel="home" class="has-logo"><picture class="vce-logo"><source media="(min-width: 1024px)" srcset="https://circuitcellar.com/wp-content/uploads/2019/08/CC_logo.png"><source srcset="https://circuitcellar.com/wp-content/uploads/2019/08/CC_logo.png"><img src="https://circuitcellar.com/wp-content/uploads/2019/08/CC_logo.png" alt="Circuit Cellar"></picture></a></span></div><nav id="site-navigation" class="main-navigation" role="navigation"><ul id="vce_main_navigation_menu" class="nav-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-114900"><a href="https://circuitcellar.com/">Home</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-231519"><a href="#">Magazine</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-230728"><a href="https://circuitcellar.com/inside-this-issue/">Inside This Issue</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114902"><a href="https://circuitcellar.com/subscription/">Subscribe</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-238664"><a href="https://simplecirc.com/subscriber_login/circuit-cellar">Subscription Management</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-242332"><a href="https://circuitcellar.com/subscription-management/">Subscription Access &#038; Help</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-114904"><a target="_blank" rel="noopener noreferrer" href="https://drive.google.com/open?id=1xeU29a9ZSZfGGtYFe625S9jttg_Ra2Oy">Article Code &#038; Files</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244275 vce-cat-3738"><a href="https://circuitcellar.com/category/article-materials-and-resources/">Article Materials and Resources</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-243659"><a target="_blank" rel="noopener noreferrer" href="http://cc-webshop.com">Purchase Back Issues</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-237551"><a href="https://circuitcellar.com/editorial-calendar/">Editorial Calendar</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114916"><a href="https://circuitcellar.com/submit/">Submit Your Technical Article</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114908"><a href="https://circuitcellar.com/errata-corrections-updates/">Errata, Corrections, &#038; Updates</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-238728"><a href="https://circuitcellar.com/circuit-cellar-newsletter-subscribe/">Circuit Cellar Newsletter</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-233724"><a href="https://circuitcellar.com/collegedigitalprogram/">College Digital Subscription Program</a></ul><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-243841 vce-cat-4715"><a href="https://circuitcellar.com/category/research-design-hub/">Research &#038; Design Hub</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243842 vce-cat-4720"><a href="https://circuitcellar.com/category/research-design-hub/basics-of-design/">Basics of Design</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-243843 vce-cat-4719"><a href="https://circuitcellar.com/category/research-design-hub/design-solutions/">Design Solutions</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243844 vce-cat-4721"><a href="https://circuitcellar.com/category/research-design-hub/projects/">Projects</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243845 vce-cat-4722"><a href="https://circuitcellar.com/category/research-design-hub/tech-trends/">Tech Trends</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243846 vce-cat-152"><a href="https://circuitcellar.com/category/research-design-hub/test-your-eq/">Test Your EQ (Engineering Quotient)</a></ul><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-243860 vce-cat-4716"><a href="https://circuitcellar.com/category/insights/">Insights</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243861 vce-cat-23"><a href="https://circuitcellar.com/category/insights/editor-letter/">Editor&#8217;s Letter</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243862 vce-cat-12"><a href="https://circuitcellar.com/category/insights/interviews/">Interviews</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243863 vce-cat-332"><a href="https://circuitcellar.com/category/insights/tech-the-future/">Tech The Future</a></ul><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-243870 vce-cat-1308"><a href="https://circuitcellar.com/category/tech-news/">Tech News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243871 vce-cat-336"><a href="https://circuitcellar.com/category/tech-news/industry-profiles/">Industry Profiles</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243872 vce-cat-82"><a href="https://circuitcellar.com/category/tech-news/product-news/">Product News</a></ul><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-243864 vce-cat-1293"><a href="https://circuitcellar.com/category/resources/">Resources</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243865 vce-cat-53"><a href="https://circuitcellar.com/category/resources/crossword/">Crossword</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243866 vce-cat-656"><a href="https://circuitcellar.com/category/resources/ee-tips/">EE Tips</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-248811 vce-cat-4952"><a href="https://circuitcellar.com/category/design-contest/">Design Contest Winning Entries</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243867 vce-cat-219"><a href="https://circuitcellar.com/category/resources/clubs/">Clubs/Organizations</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243868 vce-cat-271"><a href="https://circuitcellar.com/category/resources/professional-profiles/">Professional&#8217;s Profiles</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-243869 vce-cat-14"><a href="https://circuitcellar.com/category/resources/workspaces/">Workspaces</a></ul><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-244371 vce-cat-4782"><a href="https://circuitcellar.com/category/directories/">Directories</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244372 vce-cat-4783"><a href="https://circuitcellar.com/category/directories/datasheet/">Datasheet</a><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244373 vce-cat-4784"><a href="https://circuitcellar.com/category/directories/vendor-directory/">Vendor Directory</a></ul><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-245914"><a href="https://circuitcellar.com/mediakit/">Advertise</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-240411"><a href="https://circuitcellar.com/mediakit/">Circuit Cellar Media Kit</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-238743"><a href="https://visitor.r20.constantcontact.com/d.jsp?llr=4tkwpoeab&#038;p=oi&#038;m=1104292817535&#038;sit=upajn4wfb&#038;f=74d1a91d-9040-4a12-928d-dfaa6af2a8e7">Sign up for the Advertiser Notification Broadcast</a><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-114928"><a href="https://circuitcellar.com/editorial-calendar/">Editorial Calendar</a></ul></ul></nav></div></div><div id="main-wrapper"><div id="content" class="container site-content vce-sid-right"><div id="primary" class="vce-main-content"><main id="main" class="main-box main-box-single"><article id="post-249311" class="vce-single post-249311 post type-post status-publish format-standard has-post-thumbnail hentry category-design-solutions category-research-design-hub tag-5g tag-embedded-boards tag-fpgas tag-openvpx tag-vpx tag-wireless tag-xmc"><header class="entry-header"> <span class="meta-category"><a href="https://circuitcellar.com/category/research-design-hub/design-solutions/" class="category-4719">Design Solutions</a> <span>&bull;</span> <a href="https://circuitcellar.com/category/research-design-hub/" class="category-4715">Research &amp; Design Hub</a></span><h1 class="entry-title">Choosing Real-Time Embedded System Products</h1><div class="entry-meta"><div class="meta-item date"><span class="updated">05/06/2020</span></div></div></header><div class="meta-image"> <img width="810" height="512" src="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/Hoskings-354-lead.png?fit=810%2C512&amp;ssl=1" class="attachment-vce-lay-a size-vce-lay-a wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/Hoskings-354-lead.png?w=1243&amp;ssl=1 1243w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/Hoskings-354-lead.png?resize=300%2C189&amp;ssl=1 300w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/Hoskings-354-lead.png?resize=1000%2C632&amp;ssl=1 1000w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/Hoskings-354-lead.png?resize=150%2C95&amp;ssl=1 150w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/Hoskings-354-lead.png?resize=768%2C485&amp;ssl=1 768w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/Hoskings-354-lead.png?resize=810%2C512&amp;ssl=1 810w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/Hoskings-354-lead.png?resize=1140%2C720&amp;ssl=1 1140w" data-lazy-sizes="(max-width: 810px) 100vw, 810px" data-lazy-src="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/Hoskings-354-lead.png?fit=810%2C512&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></div><div class="meta-author"><div class="meta-author-img"> <img alt src="https://circuitcellar.com/wp-content/uploads/2020/04/354-Hosking-Head-Shot.jpg" class="avatar avatar-100 photo jetpack-lazy-image" height="100" width="100" data-lazy-srcset="https://circuitcellar.com/wp-content/uploads/2020/04/354-Hosking-Head-Shot.jpg 2x" data-lazy-src="https://circuitcellar.com/wp-content/uploads/2020/04/354-Hosking-Head-Shot.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://circuitcellar.com/wp-content/uploads/2020/04/354-Hosking-Head-Shot.jpg' srcset='https://circuitcellar.com/wp-content/uploads/2020/04/354-Hosking-Head-Shot.jpg 2x' class='avatar avatar-100 photo' height='100' width='100' /></noscript></div><div class="meta-author-wrapped">Written by <span class="vcard author"><span class="fn"><a href="https://circuitcellar.com/author/rodger-h-hosking/">Rodger H. Hosking</a></span></span></div></div><div class="entry-content"><h2 id="kt-adv-heading_5503bd-88" class="kt-adv-heading_5503bd-88 wp-block-kadence-advancedheading">10 Key Tips</h2><h3 id="kt-adv-heading_3448b7-6d" class="kt-adv-heading_3448b7-6d wp-block-kadence-advancedheading">There are many factors to consider when selecting components and board-level solutions for a real-time embedded system. In this article, Pentek’s Rodger Hosking steps through 10 key tips that can help you significantly avoid risks and reduce development efforts.</h3><p class="has-drop-cap">Real-time embedded systems require a specialized class of electronic components from vendors that can support the special needs of systems integrators. Not only must the hardware products operate across a wide range of operating modes and environments, they must also deliver performance levels meeting critical objectives for specific applications. But other factors may be even more important.</p><p>Because each project is unique, good system development tools are essential for systems integrators to deliver operational systems to their final customers as efficiently and effectively as possible. And, the vendors of these hardware and software products must help integrators choose the most appropriate products, support them during development, and then offer life cycle management solutions for continued product availability.</p><p>By following some key recommendations in making product and vendor choices, integrators can significantly avoid risks and reduce development efforts. A summary list of these tips is shown in&nbsp;<strong>Table 1</strong>.</p><figure class="wp-block-table"><table class="has-subtle-pale-blue-background-color has-background"><thead><tr><th><strong>Tips for Choosing&nbsp;Real-Time Embedded Systems</strong></th></tr></thead><tbody><tr><td>Choose open standard products for best value and life cycle</td></tr><tr><td>Define thermal management strategies early in the project</td></tr><tr><td>Identify all interconnections, including speeds and levels</td></tr><tr><td>If required, define early on how channels are synchronized</td></tr><tr><td>Identify all necessary clocking, timing, and DMA functions</td></tr><tr><td>Check for software, drivers, and examples of the above</td></tr><tr><td>Look for high-level C libraries with underlying source code</td></tr><tr><td>Identify which FPGA structures are included and supported</td></tr><tr><td>Decide who performs the required custom FPGA design efforts</td></tr><tr><td>Ensure graphical FPGA design entry tools support your boards</td></tr><tr><td>Look for AXI4-complaint FPGA IP blocks from the board vendor</td></tr><tr><td>Look for FPGA application examples from the board vendor</td></tr><tr><td>Understand the board vendor’s applications support policy</td></tr><tr><td>Look for the board vendor’s life cycle management programs</td></tr></tbody></table><figcaption><em>TABLE 1 &#8211; Checklist of critical tips for choosing real-time embedded system products</em></figcaption></figure><p><strong>HARDWARE TIPS</strong><br /><em>Open Standards:&nbsp;</em>Increasingly, both government and non-government procurement requirements now mandate or encourage compliance with emerging open-system standards for embedded hardware components. Among the many benefits are interoperability among vendors, faster deliveries and competitive pricing. Instead of replacing an entire system for a new technology upgrade, open standards allow replacement of compliant modules more quickly and at far less cost, thus extending the useful life cycle of deployed systems.</p><p>By following open standards, vendors also benefit by focusing design and development efforts on their areas of expertise, while other vendors produce complementary and compatible products to round out the supply chain. This fosters government confidence in relying upon these open standards for future long-term programs.</p><p><em>Thermal management:</em>&nbsp;As silicon device geometries continue to shrink, the power dissipation per transistor or element tends to drop, but this is often offset by increased clock rates. In addition, more elements can fit in a given size package, which drives power per device back up. Fine-pitch ball grid array packaging boosts component density of PCBs, often causing significant heat per slot in today’s embedded systems.</p><div class="SS5JDiEG" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><p style="text-align:center;font-size:10px" ;>— ADVERTISMENT—<br> <script type="text/javascript">if (document.avp_ready) { avp_zone({ base: 'linuxgizmos.advertserve.com', type: 'banner', zid: 39, pid: 3 }); }</script> <br>—<a href="/mediakit/">Advertise Here</a>—</p></div><p>When designing a new embedded system, it is imperative that designers identify heat sources for each module as early as possible. For harsh environments, the popular VPX specification defines numerous available solutions, including forced-air, air flow-though, conduction-cooling and liquid cooling. Less demanding environments are often suitable for PC platforms. Selecting the most appropriate platform and thermal management strategies at the beginning of a project can avoid costly redesign cycles and serious delays.</p><p><em>System Interfaces:</em>&nbsp;One of the toughest challenges in real-time system design is connecting system elements via data interfaces capable of handling the required traffic. Start by creating an overall system block diagram containing all essential elements, showing the data interconnect paths between them. Make sure that the interfaces on connected blocks match in type, bus width, lanes and data rates, and enter that information on the block diagram. Then, calculate and notate the worst-case data transfer rate required for each path, and compare it with the maximum path rate. This assessment of interconnect speeds will be an invaluable reference during development.</p><p>Some caveats to watch out for are interfaces that pass through several physical connectors, like a PCI Express link from an XMC module, through an XMC carrier that is plugged into a VPX backplane. Every connector can compromise maximum achievable rates. In these cases, modeling or functional test verification can help.</p><p>Shared resources, such as system memory, may have multiple contenders for access, resulting in compromised availability. Signals like received radar pulses can generate blocks of high peak rates separated intervals with no data. An elastic memory buffer (FIFO) may be required to take advantage of the low average rate for transfer across the interconnect path.</p><p><em>Synchronization:</em>&nbsp;A growing number of phased-array antenna application, including 5G wireless, airborne and SAR radars, and directional communication links, all require multiple element antennas to support beamforming for receive and transmit (<strong>Figure 1</strong>). Each antenna element signal requires precisely controlled, programmable phase shifts relative to all of the other elements.</p><div class="wp-block-image"><figure class="aligncenter size-large"><a href="https://circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_1.png"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_1.png" alt="" class="wp-image-249420 lazyload" data-srcset="https://i2.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_1.png?w=654&amp;ssl=1 654w, https://i2.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_1.png?resize=300%2C176&amp;ssl=1 300w, https://i2.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_1.png?resize=150%2C88&amp;ssl=1 150w" sizes="(max-width: 654px) 100vw, 654px" /><noscript><img src="https://i2.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_1.png?w=810&#038;ssl=1" alt="" class="wp-image-249420 lazyload" srcset="https://i2.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_1.png?w=654&amp;ssl=1 654w, https://i2.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_1.png?resize=300%2C176&amp;ssl=1 300w, https://i2.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_1.png?resize=150%2C88&amp;ssl=1 150w" sizes="(max-width: 654px) 100vw, 654px" data-recalc-dims="1" /></noscript></a><figcaption> FIGURE 1 &#8211; Massive MIMO (phased array) 5G Wireless antennas can enhance signal coverage at specific elevation and azimuth angles for faster speeds and more users.</figcaption></figure></div><p>Each signal often connects to a dedicated data converter where DSP circuitry can easily handle these precise phase shifts. However, the data converters must acquire and generate each sample at exactly the same sample clock edge. For large arrays, the high number of elements may require synchronous operation across multiple boards or chassis to handle all the channels.</p><p>Such operation can only be achieved if this feature is part of the board design, and supported with timing and sync generators connected to each board. If channel synchronization is part of the system requirement, make sure the boards inherently include this feature with recommended connectors, cables and sync generators, because synchronization is otherwise nearly impossible to add later.</p><p><em>Installed Features:</em>&nbsp;Real-time embedded boards playing typical roles in any system should include several basic functions supporting their assigned roles. For example, a single board computer (SBC) or PC motherboard will almost always implement a PCI Express root complex, system memory mapped across PCI Express address space, network interfaces, and CPU peripheral I/O like USB, serial and video. Standard CPU chip sets include virtually all of these functions, and supporting software drivers for Windows or Linux are commonly provided by the board vendor.</p><p>Other boards, like FPGA software radio modules with A/D and D/A converters, have far different roles and requirements. Commonly needed functions here include triggering, gating, time-stamping and synchronization engines that meet tight timing demands. Sample clock frequency synthesizers should accept a 10MHz system reference from an onboard GPS receiver or external source. DMA controllers must move data between the data converters and system memory through a PCI Express interface. Memory controllers for external SDRAM must buffer and capture real-time data converter streams, and communicate with the PCIe interface.</p><div class="Wve71PAO" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><p style="text-align:center;font-size:10px" ;>— ADVERTISMENT—<br> <script type="text/javascript">if (document.avp_ready) { avp_zone({ base: 'linuxgizmos.advertserve.com', type: 'banner', zid: 39, pid: 3 }); }</script> <br>—<a href="/mediakit/">Advertise Here</a>—</p></div><p>Unlike SBCs or PCs, which benefit from standard chip sets with low-level BIOS initialization, none of this exists for software radio boards. Instead, each of the hardware resources must be developed and incorporated in the FPGA. Equally important are the software libraries and drivers needed to make all of these resources work as required. Unless the board vendor includes them as factory installed features along with the supporting software libraries, the system integrator must develop, design, test, and document this on his own. To minimize risks, expense, and uncertain delays, systems integrators should make sure the board vendor includes these important resources.</p><p><strong>DEVELOPMENT TIPS</strong><br /><em>Software Development:</em>&nbsp;Although open-system architectures help with electrical and mechanical interoperability, all real-time embedded systems are a collection of diverse hardware elements that must be carefully configured for a specific, unique application. Unlike mass market PC boards with plug-and-play capabilities, most embedded boards must be explicitly configured to perform specific tasks, told how to utilize specific external input, output and timing signals and instructed what, when and how to communicate with other boards in the system. This is invariably accomplished by writing custom C programs that execute on the system controller, typically running Linux or Windows OS.</p><p>Even if an embedded board vendor provides C-callable functions for programmable hardware features, those offerings vary widely among vendors in their completeness and usability. Some offerings simply provide access to the programmable registers for the devices on the board, and the developer must use data sheets from the device manufacturer to figure out which bits to set. Even with a detailed block diagram of the board, this is very cumbersome.</p><p>In a far better approach, the board vendor offers high-level C libraries with well-documented command parameters that relate to the overall board-level operations performed, including references to other operations affected. Each of these high-level commands should include a well-organized underlying collection of low-level libraries to allow modification for specialized operations.</p><p>An even more elegant offering is a true API (application programming interface) with an API command processor program running on the system controller. In this way, API commands can be sent to the controller where they are parsed and executed, without needing to recompile a dedicated, executable C-program. API commands can be delivered to the controller via Ethernet, nicely supporting control and status functions of the embedded system from a remote client.</p><p>Last, numerous C program examples that illustrate typical operating scenarios are extremely valuable. They incorporate multiple high-level function calls with comments explaining the purpose of each, including why they must be executed in a specific order. Often these fully-tested examples can be incorporated directly into the final application to speed development. Of course, full C source code should accompany all library functions and code examples.</p><p>By selecting vendors offering these higher-level tools, systems integrators can complete their development tasks much more quickly and will be able to support changes and future upgrades far more easily.</p><p><em>FPGA Development:</em>&nbsp;FPGA designs are really hardware designs, in which the basic hardware resources of the FPGA (thousands of gates, adders, multipliers, registers, switches, memories and interfaces) are wired together to create custom circuits. The wiring connection pattern is generated by software tools from the FPGA vendor that compile descriptive instructions from the designer to create a “bitstream.” When loaded into the FPGA, the bitstream implements the required interconnects for the required circuit, often simply called “IP.”</p><p>As mentioned earlier, the board vendor may install some standard IP functions at the factory. But many customers need to install additional custom IP within the FPGA for compute-intensive, real-time algorithms. These algorithms are often the systems integrators’ “secret sauce,” comprising their critical value-added contribution to the equipment. The ease of adding IP by the customer is highly dependent on the quality of the FPGA design package supplied by the board vendor.</p><p>First of all, look for a board vendor that includes most of the essential factory-installed features, like the ones described earlier. It will dramatically reduce the overall FPGA design effort. No one wants to spend years developing a JESD204 data converter interface or a DDR4 SDRAM controller!</p><p>Next, be sure the board vendor supplies FPGA source code for all of the installed IP modules in the HDL format matching your FPGA designers’ capabilities, usually VHDL or Verilog.</p><p>Ideally, all IP from the board vendor will be delivered as AXI4 compliant blocks to match the style of reference IP blocks from the FPGA vendor. AXI4 is a widely adopted interface standard derived from ARM technology that tackles most of the housekeeping chores for connecting one IP block to another.</p><p>Take full advantage of the graphical design entry tools from the FPGA vendor, such as Xilinx’s Vivado IP Integrator. All of the AXI4 blocks are visually displayed, representing the entire block diagram of the project with all interconnects shown. IP blocks and interconnects can be added, deleted, and modified with mouse clicks, and hyperlinked documentation is available by clicking on any block. After making the required changes, the project is recompiled to produce the new design and bitstream for the FPGA.</p><p>Choose a board vendor that delivers the entire FPGA project folder containing all the files needed to create the delivered FPGA IP, fully AXI4 compliant, with complete documentation, and ready to compile using the FPGA vendor’s tool suite.</p><p><strong>VENDOR TIPS</strong><br /><em>New Technology:</em>&nbsp;One of the major benefits of open standard COTS products is upgradability of existing systems with new technology by replacing a module instead of scrapping the system and starting over. Of course, depending on the upgrade, changes will often be needed to system software and perhaps even to some of the other hardware, interfaces or connectors. Still, this is a well-proven strategy for extending the useful life of deployed equipment.</p><div class="pSl3smtQ" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><p style="text-align:center;font-size:10px" ;>— ADVERTISMENT—<br> <script type="text/javascript">if (document.avp_ready) { avp_zone({ base: 'linuxgizmos.advertserve.com', type: 'banner', zid: 39, pid: 3 }); }</script> <br>—<a href="/mediakit/">Advertise Here</a>—</p></div><p>Choose board vendors with a history of consistently delivering open-standards products based on each new generation of FPGAs, data converters, memories, and system interfaces. Look for high-level development tools from those vendors to simplify the migration of software and FPGA designs.</p><p><em>Applications Support:</em>&nbsp;Because every embedded system tends to be unique, systems integrators invariably encounter first-time configurations of multi-vendor products that don’t seem to work as expected. Too often, each vendor blames another vendor for the problem, leaving the integrator on his own. Choose vendors with a proven track record of solving problems, regardless of who is at fault and share such experiences with other project teams.</p><p>Most board vendors offer contracts to provide technical support during the development phase, although the quality and timeliness of that support varies among vendors. When the support contract runs out, before they can get additional help, customers will either be asked to renew the contract, or for a credit card number. Some vendors offer free support for a limited time or number of hours, with payment required thereafter.</p><p>Be sure to ask any potential vendor for written descriptions of the applications support policies and costs before purchasing his products.</p><p><em>Life Cycle Management:</em>&nbsp;Often, a significant concern for systems integrators is the increasing prevalence of component obsolescence, or end-of-life. This causes two major problems. Future component availability can jeopardize on-going production of enough boards to support multi-year installation program cycles. Also, 20- to 30-year maintenance contracts to support these fielded systems are at risk without components needed for repairs.</p><p>Systems integrators naturally look to the board vendors for help, and various strategies have emerged. The simplest one is to purchase and produce enough additional boards up front to cover all installations over the life of the program, plus spares to cover the expected number of failures. End customers usually balk at the cost of this approach.</p><p>A very cost-effective alternative is a bonded inventory component program. The board vendor purchases all of the active components needed for the production of the total number of boards required over the life of the program, plus extras for repairs. The customer agrees to pay for these components, which the vendor reserves for him in bonded inventory. When production is required, those parts are used and their cost is credited toward the new purchase.</p><p>Since components such as PCBs and hardware can always be purchased as needed for later production, the cost of this bonded inventory program is a small fraction of the cost of full production up front, and very attractive to most customers.</p><p><strong>PUTTING IT ALL TOGETHER</strong><br />As an example of these strategies developed over three decades, Pentek’s latest offering is the Model 5950 Quartz RFSoC 3U VPX module (<strong>Figure 2</strong>). Following the VITA 65 OpenVPX standard, this powerful software radio board combines eight channels of wideband A/D and D/A conversion, a wealth of Xilinx Zynq UltraScale+ FPGA resources, and a multi-core Arm processor to handle system controller functions.</p><div class="wp-block-image"><figure class="aligncenter size-large"><a href="https://circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_2.jpg"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_2.jpg" alt="" class="wp-image-249421 lazyload" data-srcset="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_2.jpg?w=389&amp;ssl=1 389w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_2.jpg?resize=203%2C300&amp;ssl=1 203w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_2.jpg?resize=101%2C150&amp;ssl=1 101w" sizes="(max-width: 389px) 100vw, 389px" /><noscript><img src="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_2.jpg?w=810&#038;ssl=1" alt="" class="wp-image-249421 lazyload" srcset="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_2.jpg?w=389&amp;ssl=1 389w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_2.jpg?resize=203%2C300&amp;ssl=1 203w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354_Hosking_Figure_2.jpg?resize=101%2C150&amp;ssl=1 101w" sizes="(max-width: 389px) 100vw, 389px" data-recalc-dims="1" /></noscript></a><figcaption> FIGURE 2 &#8211; Pentek Model 5950 Zynq UltraScale+ RFSoC 8 Channel A/D and D/A VPX module.</figcaption></figure></div><p>Factory-installed features include IP for wideband data acquisition, triggering, timing, and multi-channel synchronization. A waveform generation engine creates analog signals from customer-created waveform tables or from an on-board frequency synthesizer and chirp generator. Linked-list DMA controllers move data from the board to and from the PCIe Gen.3 x8 interfaces and two 100GigE interfaces, each capable of sustaining 12GB/s.</p><p>All of these resources are supported with software development tools under the Pentek Navigator Board Support package. It includes a high-level API, C-language libraries, a command processor for the Arm, complete C source code, and fully functional starter applications. For custom FPGA development Pentek’s Navigator FPGA Design Kit contains the complete Xilinx Vivado project for the Model 5950, and a library of over 140 Pentek AXI4 IP modules for adding new features.</p><p>Pentek offers free lifetime applications support and well-development life cycle management and bonded inventory programs. By introducing a constant stream of industry-leading, open standard board level products with the latest data converters and FPGAs, Pentek helps systems integrators to take earliest advantage of the newest technology.&nbsp;</p><p>For detailed article references and additional resources go to:<br />www.circuitcellar.com/article-materials</p><p><strong>RESOURCES</strong><br />Pentek |&nbsp;<a href="http://www.pentek.com">www.pentek.com</a></p><p> PUBLISHED IN CIRCUIT CELLAR MAGAZINE • JANUARY 2020 #354 &#8211; <a href="http://cc-webshop.com">Get a PDF of the issue</a></p><div class="widget_text awac-wrapper"><div class="widget_text awac widget custom_html-4"><div class="textwidget custom-html-widget"><hr /><p>Don't miss out on upcoming issues of <em>Circuit Cellar.</em> Subscribe today!</p><div align="center"><a class="button" style="border: 1px solid #5b5b5b; color: #0000ff; display: inline-block; padding: 8px 10px; text-shadow: none; border-top-left-radius: 10px; border-top-right-radius: 10px; border-bottom-right-radius: 10px; border-bottom-left-radius: 10px; background-color: #ffffff;" href="/subscription/">CC Subscribe</a></div><div align="center"> </div><div style="text-align: left;" align="center"> </div><div style="text-align: left;" align="center">Note: We’ve made the <a href="https://www.calameo.com/read/0053543531244a66077da" target="_blank" rel="noopener noreferrer">October 2017 issue of Circuit Cellar </a>available as a free sample issue. In it, you’ll find a rich variety of the kinds of articles and information that exemplify a typical issue of the current magazine.</div><hr /> <br /><b> Would you like to write for <i>Circuit Cellar</i>? We are always accepting articles/posts from the technical community. <a href='/submit/'>Get in touch with us and let's discuss your ideas.</a></b></div></div></div></p> <a class="ss-content-placeholder" href="https://circuitcellar.com/sponsor/?ss_content_id=249311"><div class="ss-placeholder-image"><svg aria-hidden="true" class="svg-inline--fa fa-id-card-alt fa-w-18" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 576 512"><path fill="currentColor" d="M288 208c-44.2 0-80 35.8-80 80s35.8 80 80 80 80-35.8 80-80-35.8-80-80-80zm0 128c-26.5 0-48-21.5-48-48s21.5-48 48-48 48 21.5 48 48-21.5 48-48 48zM512 64H352V32c0-17.7-14.3-32-32-32h-64c-17.7 0-32 14.3-32 32v32H64C28.7 64 0 92.7 0 128v320c0 35.3 28.7 64 64 64h448c35.3 0 64-28.7 64-64V128c0-35.3-28.7-64-64-64zM256 32h64v96h-64V32zm128 448H192v-21.9c0-9 2.6-17.6 7.6-25 7.2-10.7 20.3-17.2 35-17.2 15.9 0 23.5 8 53.4 8s37.6-8 53.4-8c14.7 0 27.7 6.4 35 17.2 5 7.4 7.6 16 7.6 25V480zm160-32c0 17.6-14.4 32-32 32h-96v-21.9c0-15.9-4.8-30.6-13-42.8-13.8-20.5-37.3-31.3-61.5-31.3-22.2 0-27.8 8-53.4 8-25.6 0-31.2-8-53.4-8-24.2 0-47.7 10.8-61.5 31.3-8.2 12.2-13 27-13 42.8V480H64c-17.6 0-32-14.4-32-32V128c0-17.6 14.4-32 32-32h160v64h128V96h160c17.6 0 32 14.4 32 32v320z"></path></svg></div> Become a Sponsor </a>  <div class="molongui-clearfix"></div><div id="mab-1586152599" class="m-a-box" data-plugin-release="4.1.0" data-plugin-version="pro" data-box-layout="slim" data-box-position="below" data-multiauthor="false" data-author-type="guest" itemscope itemtype="https://schema.org/Person" style="width: 100%;            margin: 20px auto;"><div class="m-a-box-container
 molongui-border-style-solid                molongui-border-width-2-px
 m-a-box-shadow-right" style="border-color: #a5a5a5;                background-color: #e6e6e6;"><div class="m-a-box-tab m-a-box-content m-a-box-profile" data-profile-layout="layout-1" data-author-ref="guest-249313"><div class="m-a-box-content-top"></div><div class="m-a-box-content-middle"> <div class="m-a-box-item m-a-box-avatar "> <a href="https://circuitcellar.com/author/rodger-h-hosking/"> <img width="150" height="144" src="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354-Hosking-Head-Shot.jpg?fit=150%2C144&amp;ssl=1" class="m-radius-none molongui-border-style-solid molongui-border-width-1-px wp-post-image jetpack-lazy-image" alt="" style="border-color:inherit;" itemprop="image" data-lazy-srcset="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354-Hosking-Head-Shot.jpg?w=754&amp;ssl=1 754w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354-Hosking-Head-Shot.jpg?resize=300%2C288&amp;ssl=1 300w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354-Hosking-Head-Shot.jpg?resize=150%2C144&amp;ssl=1 150w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/354-Hosking-Head-Shot.jpg?fit=150%2C144&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a></div>  <div class="m-a-box-item m-a-box-data "> <div class="m-a-box-title"><h5 class="molongui-font-size-16-px
 molongui-text-align-left                        molongui-text-case-none" style="color: inherit" itemprop="name"> <a href="https://circuitcellar.com/author/rodger-h-hosking/" class=" molongui-font-size-16-px molongui-text-align-left " style="color:inherit;" itemprop="url"> Rodger H. Hosking </a></h5></div> <div class="m-a-box-item m-a-box-meta
 molongui-font-size-11-px
 molongui-text-align-left                        molongui-text-case-none" style="color: inherit"> <span itemprop="jobTitle"></span> <span itemprop="worksFor" itemscope itemtype="https://schema.org/Organization"> <span itemprop="name"></span> </span></div> <div class="m-a-box-bio" itemprop="description"><div class="molongui-font-size-14-px molongui-text-align-justify  molongui-line-height-10" style="color: inherit"><div id="_idContainer018" class="Author-Object _idGenObjectStyleOverride-5"><p class="Author-Bio-Content ParaOverride-4">Rodger H. Hosking is vice-president and co-founder of Pentek, where he is responsible for new product definition, technology development and strategic alliances. With over 30 years in the electronics industry, he has authored hundreds of articles about software radio and digital signal processing. Prior to his current position, he served as engineering manager at Wavetek/Rockland, and holds patents in frequency synthesis and spectrum analysis techniques. He holds a BS degree in Physics from Allegheny College and BSEE and MSEE degrees from Columbia University in New York.</p></div></div></div> <div class="m-a-box-related" data-related-layout="layout-1"><div class="m-a-box-item m-a-box-related-entries" style="display: none;"><ul class="molongui-font-size-14-px " style="color: inherit"> <span class="m-a-box-string-no-related-posts">This author does not have any more posts.</span></ul></div></div></div></div><div class="m-a-box-content-bottom"></div></div></div></div></div><footer class="entry-footer"><div class="meta-tags"> <a href="https://circuitcellar.com/tag/5g/" rel="tag">5G</a> <a href="https://circuitcellar.com/tag/embedded-boards/" rel="tag">embedded boards</a> <a href="https://circuitcellar.com/tag/fpgas/" rel="tag">FPGAs</a> <a href="https://circuitcellar.com/tag/openvpx/" rel="tag">OpenVPX</a> <a href="https://circuitcellar.com/tag/vpx/" rel="tag">VPX</a> <a href="https://circuitcellar.com/tag/wireless/" rel="tag">wireless</a> <a href="https://circuitcellar.com/tag/xmc/" rel="tag">XMC</a></div></footer><div class="vce-share-bar"><ul class="vce-share-items"><div class="meks_ess rectangle no-labels"><a href="javascript:void(0);" class="meks_ess-item socicon-facebook" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fcircuitcellar.com%2Fresearch-design-hub%2Fchoosing-real-time-embedded-system-products%2F&amp;t=Choosing%20Real-Time%20Embedded%20System%20Products"><span>Facebook</span></a><a href="javascript:void(0);" class="meks_ess-item socicon-twitter" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fcircuitcellar.com%2Fresearch-design-hub%2Fchoosing-real-time-embedded-system-products%2F&amp;text=Choosing%20Real-Time%20Embedded%20System%20Products"><span>Twitter</span></a><a href="javascript:void(0);" class="meks_ess-item socicon-linkedin" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fcircuitcellar.com%2Fresearch-design-hub%2Fchoosing-real-time-embedded-system-products%2F&amp;title=Choosing%20Real-Time%20Embedded%20System%20Products"><span>LinkedIn</span></a><a href="javascript:void(0);" class="meks_ess-item socicon-reddit" data-url="http://www.reddit.com/submit?url=https%3A%2F%2Fcircuitcellar.com%2Fresearch-design-hub%2Fchoosing-real-time-embedded-system-products%2F&amp;title=Choosing%20Real-Time%20Embedded%20System%20Products"><span>Reddit</span></a></div></ul></div></article><nav class="prev-next-nav"><div class="vce-prev-link"> <a href="https://circuitcellar.com/tech-news/product-news/600w-fanless-ac-dc-supplies-target-medical/" rel="next"><span class="img-wrp"><img width="375" height="195" src="https://i2.wp.com/circuitcellar.com/wp-content/uploads/2020/04/uch600pr-Copy.jpg?resize=375%2C195&amp;ssl=1" class="attachment-vce-lay-b size-vce-lay-b wp-post-image jetpack-lazy-image" alt="" data-lazy-src="https://i2.wp.com/circuitcellar.com/wp-content/uploads/2020/04/uch600pr-Copy.jpg?resize=375%2C195&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><span class="vce-pn-ico"><i class="fa fa fa-chevron-left"></i></span></span><span class="vce-prev-next-link">600W Fanless AC-DC Supplies Target Medical</span></a></div><div class="vce-next-link"> <a href="https://circuitcellar.com/tech-news/product-news/carrier-boards-support-jetson-nano-modules/" rel="prev"><span class="img-wrp"><img width="375" height="195" src="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/gumstix_nano_snapshot.jpg?resize=375%2C195&amp;ssl=1" class="attachment-vce-lay-b size-vce-lay-b wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/gumstix_nano_snapshot.jpg?resize=375%2C195&amp;ssl=1 375w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/gumstix_nano_snapshot.jpg?zoom=2&amp;resize=375%2C195&amp;ssl=1 750w" data-lazy-sizes="(max-width: 375px) 100vw, 375px" data-lazy-src="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/04/gumstix_nano_snapshot.jpg?resize=375%2C195&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /><span class="vce-pn-ico"><i class="fa fa fa-chevron-right"></i></span></span><span class="vce-prev-next-link">Carrier Boards Support Jetson Nano Modules</span></a></div></nav></main><div class="main-box vce-related-box"><h3 class="main-box-title">You may also like</h3><div class="main-box-inside"><article class="vce-post vce-lay-d post-251633 post type-post status-publish format-standard has-post-thumbnail hentry category-newsletter tag-iot tag-lora tag-lorawan tag-smart-locks tag-wireless"><div class="meta-image"> <a href="https://circuitcellar.com/newsletter/semtech-lora-ics-tapped-for-smart-door-locks/" title="Semtech LoRa ICs Tapped for Smart Door Locks"> <img width="145" height="100" src="https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/07/LoRa_H3C_SmartCampusLock_Web_750x422px.jpg?resize=145%2C100&amp;ssl=1" class="attachment-vce-lay-d size-vce-lay-d wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/07/LoRa_H3C_SmartCampusLock_Web_750x422px.jpg?resize=145%2C100&amp;ssl=1 145w, https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/07/LoRa_H3C_SmartCampusLock_Web_750x422px.jpg?resize=380%2C260&amp;ssl=1 380w, https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/07/LoRa_H3C_SmartCampusLock_Web_750x422px.jpg?zoom=2&amp;resize=145%2C100&amp;ssl=1 290w, https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/07/LoRa_H3C_SmartCampusLock_Web_750x422px.jpg?zoom=3&amp;resize=145%2C100&amp;ssl=1 435w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/07/LoRa_H3C_SmartCampusLock_Web_750x422px.jpg?resize=145%2C100&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://circuitcellar.com/category/newsletter/" class="category-4920">Newsletter</a></span><h2 class="entry-title"><a href="https://circuitcellar.com/newsletter/semtech-lora-ics-tapped-for-smart-door-locks/" title="Semtech LoRa ICs Tapped for Smart Door Locks">Semtech LoRa ICs Tapped for Smart Door Locks</a></h2></header></article><article class="vce-post vce-lay-d post-251630 post type-post status-publish format-standard has-post-thumbnail hentry category-newsletter tag-antenna tag-iot tag-wi-fi tag-wi-fi-6e tag-wireless"><div class="meta-image"> <a href="https://circuitcellar.com/newsletter/antenna-serves-wi-fi-6-and-wi-fi-6e-needs/" title="Antenna Serves Wi-Fi 6 and Wi-Fi 6E Needs"> <img width="145" height="100" src="https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/07/ant-w63ws3-sma.png?resize=145%2C100&amp;ssl=1" class="attachment-vce-lay-d size-vce-lay-d wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/07/ant-w63ws3-sma.png?resize=145%2C100&amp;ssl=1 145w, https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/07/ant-w63ws3-sma.png?resize=380%2C260&amp;ssl=1 380w, https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/07/ant-w63ws3-sma.png?resize=634%2C433&amp;ssl=1 634w, https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/07/ant-w63ws3-sma.png?zoom=2&amp;resize=145%2C100&amp;ssl=1 290w, https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/07/ant-w63ws3-sma.png?zoom=3&amp;resize=145%2C100&amp;ssl=1 435w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/07/ant-w63ws3-sma.png?resize=145%2C100&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://circuitcellar.com/category/newsletter/" class="category-4920">Newsletter</a></span><h2 class="entry-title"><a href="https://circuitcellar.com/newsletter/antenna-serves-wi-fi-6-and-wi-fi-6e-needs/" title="Antenna Serves Wi-Fi 6 and Wi-Fi 6E Needs">Antenna Serves Wi-Fi 6 and Wi-Fi 6E Needs</a></h2></header></article><article class="vce-post vce-lay-d post-251403 post type-post status-publish format-standard has-post-thumbnail hentry category-newsletter tag-consumer-devices tag-iot tag-mcu tag-microcontrollers tag-wireless"><div class="meta-image"> <a href="https://circuitcellar.com/newsletter/wi-fi-expresso-machine-uses-esp32-mcu/" title="Wi-Fi Expresso Machine Uses ESP32 MCU"> <img width="145" height="100" src="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/07/Screenshot-2020-06-23-at-13.26.36.png?resize=145%2C100&amp;ssl=1" class="attachment-vce-lay-d size-vce-lay-d wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/07/Screenshot-2020-06-23-at-13.26.36.png?resize=145%2C100&amp;ssl=1 145w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/07/Screenshot-2020-06-23-at-13.26.36.png?resize=380%2C260&amp;ssl=1 380w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/07/Screenshot-2020-06-23-at-13.26.36.png?zoom=2&amp;resize=145%2C100&amp;ssl=1 290w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/07/Screenshot-2020-06-23-at-13.26.36.png?zoom=3&amp;resize=145%2C100&amp;ssl=1 435w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/07/Screenshot-2020-06-23-at-13.26.36.png?resize=145%2C100&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://circuitcellar.com/category/newsletter/" class="category-4920">Newsletter</a></span><h2 class="entry-title"><a href="https://circuitcellar.com/newsletter/wi-fi-expresso-machine-uses-esp32-mcu/" title="Wi-Fi Expresso Machine Uses ESP32 MCU">Wi-Fi Expresso Machine Uses ESP32 MCU</a></h2></header></article><article class="vce-post vce-lay-d post-251397 post type-post status-publish format-standard has-post-thumbnail hentry category-newsletter tag-industrial-iot tag-iot tag-mcu tag-microcontrollers tag-wireless tag-zigbee"><div class="meta-image"> <a href="https://circuitcellar.com/newsletter/stm32-wireless-mcus-get-zigbee-3-0-support/" title="STM32 Wireless MCUs Get Zigbee 3.0 Support"> <img width="145" height="100" src="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/07/Zigbee_stack_STM32WB_MCUs_N4256S_big.jpg?resize=145%2C100&amp;ssl=1" class="attachment-vce-lay-d size-vce-lay-d wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/07/Zigbee_stack_STM32WB_MCUs_N4256S_big.jpg?resize=145%2C100&amp;ssl=1 145w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/07/Zigbee_stack_STM32WB_MCUs_N4256S_big.jpg?resize=380%2C260&amp;ssl=1 380w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/07/Zigbee_stack_STM32WB_MCUs_N4256S_big.jpg?resize=634%2C433&amp;ssl=1 634w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/07/Zigbee_stack_STM32WB_MCUs_N4256S_big.jpg?zoom=2&amp;resize=145%2C100&amp;ssl=1 290w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/07/Zigbee_stack_STM32WB_MCUs_N4256S_big.jpg?zoom=3&amp;resize=145%2C100&amp;ssl=1 435w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/07/Zigbee_stack_STM32WB_MCUs_N4256S_big.jpg?resize=145%2C100&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://circuitcellar.com/category/newsletter/" class="category-4920">Newsletter</a></span><h2 class="entry-title"><a href="https://circuitcellar.com/newsletter/stm32-wireless-mcus-get-zigbee-3-0-support/" title="STM32 Wireless MCUs Get Zigbee 3.0 Support">STM32 Wireless MCUs Get Zigbee 3.0 Support</a></h2></header></article><article class="vce-post vce-lay-d post-251038 post type-post status-publish format-standard has-post-thumbnail hentry category-newsletter tag-carrier-boards tag-com-express tag-embedded-boards tag-smarc"><div class="meta-image"> <a href="https://circuitcellar.com/newsletter/size-optimized-smarc-2-1-carrier-board-rolls/" title="Size-Optimized SMARC 2.1 Carrier Board Rolls"> <img width="145" height="100" src="https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/06/csm_conga-smc1x86_f3d257567c.jpg?resize=145%2C100&amp;ssl=1" class="attachment-vce-lay-d size-vce-lay-d wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/06/csm_conga-smc1x86_f3d257567c.jpg?resize=145%2C100&amp;ssl=1 145w, https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/06/csm_conga-smc1x86_f3d257567c.jpg?resize=380%2C260&amp;ssl=1 380w, https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/06/csm_conga-smc1x86_f3d257567c.jpg?resize=634%2C433&amp;ssl=1 634w, https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/06/csm_conga-smc1x86_f3d257567c.jpg?zoom=2&amp;resize=145%2C100&amp;ssl=1 290w, https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/06/csm_conga-smc1x86_f3d257567c.jpg?zoom=3&amp;resize=145%2C100&amp;ssl=1 435w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://i1.wp.com/circuitcellar.com/wp-content/uploads/2020/06/csm_conga-smc1x86_f3d257567c.jpg?resize=145%2C100&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://circuitcellar.com/category/newsletter/" class="category-4920">Newsletter</a></span><h2 class="entry-title"><a href="https://circuitcellar.com/newsletter/size-optimized-smarc-2-1-carrier-board-rolls/" title="Size-Optimized SMARC 2.1 Carrier Board Rolls">Size-Optimized SMARC 2.1 Carrier Board Rolls</a></h2></header></article><article class="vce-post vce-lay-d post-251035 post type-post status-publish format-standard has-post-thumbnail hentry category-newsletter tag-embedded-boards tag-industrial tag-iot tag-mini-itx tag-sbc"><div class="meta-image"> <a href="https://circuitcellar.com/newsletter/mini-itx-sbc-sports-8th-gen-core-processor/" title="Mini-ITX SBC Sports 8th Gen Core Processor"> <img width="145" height="100" src="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/06/WIN-Enterprises-MB-50040-Hi-Res.jpg?resize=145%2C100&amp;ssl=1" class="attachment-vce-lay-d size-vce-lay-d wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/06/WIN-Enterprises-MB-50040-Hi-Res.jpg?resize=145%2C100&amp;ssl=1 145w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/06/WIN-Enterprises-MB-50040-Hi-Res.jpg?resize=380%2C260&amp;ssl=1 380w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/06/WIN-Enterprises-MB-50040-Hi-Res.jpg?resize=634%2C433&amp;ssl=1 634w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/06/WIN-Enterprises-MB-50040-Hi-Res.jpg?zoom=2&amp;resize=145%2C100&amp;ssl=1 290w, https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/06/WIN-Enterprises-MB-50040-Hi-Res.jpg?zoom=3&amp;resize=145%2C100&amp;ssl=1 435w" data-lazy-sizes="(max-width: 145px) 100vw, 145px" data-lazy-src="https://i0.wp.com/circuitcellar.com/wp-content/uploads/2020/06/WIN-Enterprises-MB-50040-Hi-Res.jpg?resize=145%2C100&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a></div><header class="entry-header"> <span class="meta-category"><a href="https://circuitcellar.com/category/newsletter/" class="category-4920">Newsletter</a></span><h2 class="entry-title"><a href="https://circuitcellar.com/newsletter/mini-itx-sbc-sports-8th-gen-core-processor/" title="Mini-ITX SBC Sports 8th Gen Core Processor">Mini-ITX SBC Sports 8th Gen Core Processor</a></h2></header></article></div></div></div><aside id="sidebar" class="sidebar right"><div id="custom_html-3" class="widget_text vce-no-padding widget widget_custom_html"><div class="textwidget custom-html-widget"> <script type="text/javascript">if (document.avp_ready) { avp_zone({ base: 'linuxgizmos.advertserve.com', type: 'banner', zid: 38, pid: 3 }); }</script>  &nbsp; Magazine Sponsor &nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &mdash; <a href="https://circuitcellar.com/mediakit/"> ADVERTISE </a></div></div><div id="custom_html-2" class="widget_text vce-no-padding widget widget_custom_html"><div class="textwidget custom-html-widget">ADVERTISMENTS  <script type="text/javascript">if (document.avp_ready) { avp_multiple({ base: 'linuxgizmos.advertserve.com', type: 'banner', zid: 37, pid: 3, total: 15, renderer: 'strip', layout: 'vertical', margin: 0, padding: 6 }); }</script> </div></div><div id="custom_html-5" class="widget_text vce-no-padding widget widget_custom_html"><div class="textwidget custom-html-widget"> <script type="text/javascript">if (document.avp_ready) { avp_campaign({ base: 'linuxgizmos.advertserve.com', type: 'banner', cid: 3, sid: 8, pid: 0 }); }</script> </div></div></aside></div><footer id="footer" class="site-footer"><div class="container"><div class="container-fix"><div class="bit-3"><div id="custom_html-10" class="widget_text widget widget_custom_html"><h4 class="widget-title">Supporting Companies</h4><div class="textwidget custom-html-widget"><div class="n2-section-smartslider fitvidsignore " role="region" aria-label="Slider"><style>div#n2-ss-2 .nextend-spinnerhidden{position:absolute;left:-10000px;}div#n2-ss-2 .nextend-spinner{position:absolute;top:50%;left:50%;margin:-25px 0 0 -15px;z-index:1000;width:50px;height:30px;text-align:center;font-size:10px;background-color:RGBA(0,0,0,0.6);border-radius:3px;padding:10px 15px;}div#n2-ss-2 .nextend-spinner > div{background-color:#f6f6f6;height:100%;width:6px;display:inline-block;animation:nextendstretchdelay 1.2s infinite ease-in-out;}div#n2-ss-2 .nextend-spinner .rect2{animation-delay:-1.1s;}div#n2-ss-2 .nextend-spinner .rect3{animation-delay:-1s;}div#n2-ss-2 .nextend-spinner .rect4{animation-delay:-0.9s;}div#n2-ss-2 .nextend-spinner .rect5{animation-delay:-0.8s;}@keyframes nextendstretchdelay{0%,40%,100%{transform:scaleY(0.4);}20%{transform:scaleY(1.0);}}div#n2-ss-2{width:400px;margin:0px 0px 0px 0px;}div#n2-ss-2 .n2-ss-slider-1{position:relative;}div#n2-ss-2 .n2-ss-slider-2{position:relative;overflow:hidden;border:0px solid RGBA(62,62,62,1);border-radius:0px;background-repeat:repeat;background-position:50% 50%;background-size:cover;background-attachment:scroll;background-color:RGBA(255,255,255,1);z-index:1;}div#n2-ss-2.n2-ss-mobileLandscape .n2-ss-slider-2,div#n2-ss-2.n2-ss-mobilePortrait .n2-ss-slider-2{background-attachment:scroll;}div#n2-ss-2 .n-particles-js-canvas-el{position:absolute;left:0;top:0;width:100%;height:100%;z-index:12;}div#n2-ss-2 .n2-ss-slider-3{position:relative;height:200px;overflow:hidden;z-index:20;}div#n2-ss-2 .n2-ss-slider-pane{position:relative;width:100%;height:100%;overflow:hidden;}div#n2-ss-2 .n2-ss-slide-group{display:flex;position:absolute;left:0;top:0;width:100%;height:100%;}div#n2-ss-2 .n2-ss-slide{display:block;position:absolute;top:0;width:250px;height:160px;border-radius:5px;background-clip:padding-box;background-color:RGBA(255,255,255,0);z-index:1;border:0px solid ;box-sizing:border-box;}div#n2-ss-2 .n2-ss-layers-container{position:relative;}div#n2-ss-2 .n2-ss-slide{perspective:1000px;}div#n2-ss-2[data-ie] .n2-ss-slide{perspective:none;transform:perspective(1000px);}div#n2-ss-2 .n2-ss-slide-active{z-index:3;}div#n2-ss-2 .n2-ss-layer{-webkit-backface-visibility:hidden;}div#n2-ss-2 .n2-ss-control-bullet{visibility:hidden;text-align:center;justify-content:center;}div#n2-ss-2 .n2-ss-control-bullet--calculate-size{left:0 !important;}div#n2-ss-2 .n2-ss-control-bullet-horizontal.n2-ss-control-bullet-fullsize{width:100%;}div#n2-ss-2 .n2-ss-control-bullet-vertical.n2-ss-control-bullet-fullsize{height:100%;flex-flow:column;}div#n2-ss-2 .nextend-bullet-bar{display:inline-flex;visibility:visible;align-items:center;flex-wrap:wrap;}div#n2-ss-2 .n2-bar-justify-content-left{justify-content:flex-start;}div#n2-ss-2 .n2-bar-justify-content-center{justify-content:center;}div#n2-ss-2 .n2-bar-justify-content-right{justify-content:flex-end;}div#n2-ss-2 .n2-ss-control-bullet-vertical > .nextend-bullet-bar{flex-flow:column;}div#n2-ss-2 .n2-ss-control-bullet-fullsize > .nextend-bullet-bar{display:flex;}div#n2-ss-2 .n2-ss-control-bullet-horizontal.n2-ss-control-bullet-fullsize > .nextend-bullet-bar{flex:1 1 auto;}div#n2-ss-2 .n2-ss-control-bullet-vertical.n2-ss-control-bullet-fullsize > .nextend-bullet-bar{height:100%;}div#n2-ss-2 .nextend-bullet-bar .n2-bullet{cursor:pointer;transition:background-color 0.4s;}div#n2-ss-2 .nextend-bullet-bar .n2-bullet.n2-active{cursor:default;}div#n2-ss-2 div.n2-ss-bullet-thumbnail-container{position:absolute;opacity:0;z-index:10000000;}div#n2-ss-2 .n2-ss-bullet-thumbnail-container .n2-ss-bullet-thumbnail{background-size:cover;background-repeat:no-repeat;background-position:center;}div#n2-ss-2 .n2-style-73564f4d22082e0ff5a5b8328cf7d2f8-dot{background: #e1e6e7;opacity:1;padding:5px 5px 5px 5px ;box-shadow: none;border-width: 0px;border-style: solid;border-color: #000000; border-color: RGBA(0,0,0,1);border-radius:50px;margin: 4px;}div#n2-ss-2 .n2-style-73564f4d22082e0ff5a5b8328cf7d2f8-dot.n2-active, div#n2-ss-2 .n2-style-73564f4d22082e0ff5a5b8328cf7d2f8-dot:HOVER, div#n2-ss-2 .n2-style-73564f4d22082e0ff5a5b8328cf7d2f8-dot:FOCUS{background: #42afe3;}</style><div id="n2-ss-2-align" class="n2-ss-align"><div class="n2-padding"><div id="n2-ss-2" data-creator="Smart Slider 3" class="n2-ss-slider n2-ow n2-has-hover n2notransition  n2-ss-load-fade " style="font-size: 1rem;" data-fontsize="16"><div class="n2-ss-slider-1 n2_ss__touch_element n2-ow"><div class="n2-ss-slider-2 n2-ow" style=""><div class="n2-ss-slider-3 n2-ow"><div class="n2-ss-slider-pane n2-ow"><div data-first="1" data-slide-duration="0" data-id="13" data-title="Accutrace" data-haslink="1" style="cursor:pointer;" onclick="" data-href="http://www.pcb4u.com/" data-target="_blank" data-n2click="n2ss.openUrl(e);" data-n2middleclick="n2ss.openUrl(e, &#039;_blank&#039;);" class=" n2-ss-slide  n2-ss-slide-13 n2-ss-canvas n2-ow"><div class="n2-ss-slide-background n2-ow" data-mode="fit"><div data-hash="68dcf768711ce38727a093a82107cea1" data-desktop="//circuitcellar.com/wp-content/uploads/2019/09/Accutrace.jpg" class="n2-ss-slide-background-image" data-blur="0" data-alt="" data-title=""></div></div><div class="n2-ss-layers-container n2-ow"><div class="n2-ss-layer n2-ow" style="padding:0px 0px 0px 0px;" data-desktopportraitpadding="0|*|0|*|0|*|0" data-sstype="slide" data-csstextalign="center" data-pm="default"></div></div></div><div data-slide-duration="0" data-id="14" data-title="ez-pcb-logo" data-haslink="1" style="cursor:pointer;" onclick="" data-href="https://www.ezpcb.com/" data-target="_blank" data-n2click="n2ss.openUrl(e);" data-n2middleclick="n2ss.openUrl(e, &#039;_blank&#039;);" class=" n2-ss-slide  n2-ss-slide-14 n2-ss-canvas n2-ow"><div class="n2-ss-slide-background n2-ow" data-mode="fit"><div data-hash="8aaa111532dac6e3b1eb4384f33ddcbb" data-desktop="//circuitcellar.com/wp-content/uploads/2019/10/EzPCB.jpg" class="n2-ss-slide-background-image" data-blur="0" data-alt="EzPCB" data-title="EzPCB"></div></div><div class="n2-ss-layers-container n2-ow"><div class="n2-ss-layer n2-ow" style="padding:0px 0px 0px 0px;" data-desktopportraitpadding="0|*|0|*|0|*|0" data-sstype="slide" data-csstextalign="center" data-pm="default"></div></div></div><div data-slide-duration="0" data-id="15" data-title="segger-logo" data-haslink="1" style="cursor:pointer;" onclick="" data-href="https://www.segger.com/" data-target="_blank" data-n2click="n2ss.openUrl(e);" data-n2middleclick="n2ss.openUrl(e, &#039;_blank&#039;);" class=" n2-ss-slide  n2-ss-slide-15 n2-ss-canvas n2-ow"><div class="n2-ss-slide-background n2-ow" data-mode="fit"><div data-hash="56169f917e1e29cbfcdb44208479b59d" data-desktop="//circuitcellar.com/wp-content/uploads/2019/09/segger-logo.jpg" class="n2-ss-slide-background-image" data-blur="0" data-alt="SEGGER" data-title="SEGGER"></div></div><div class="n2-ss-layers-container n2-ow"><div class="n2-ss-layer n2-ow" style="padding:0px 0px 0px 0px;" data-desktopportraitpadding="0|*|0|*|0|*|0" data-sstype="slide" data-csstextalign="center" data-pm="default"></div></div></div><div data-slide-duration="0" data-id="153" data-title="Humandata" data-haslink="1" style="cursor:pointer;" onclick="" data-href="www2.hdl.co.jp/CC19B" data-target="_blank" data-n2click="n2ss.openUrl(e);" data-n2middleclick="n2ss.openUrl(e, &#039;_blank&#039;);" class=" n2-ss-slide  n2-ss-slide-153 n2-ss-canvas n2-ow"><div class="n2-ss-slide-background n2-ow" data-mode="fit"><div data-hash="85df2d749ee793d7e66b85ad6ea3ee4b" data-desktop="//circuitcellar.com/wp-content/uploads/2019/10/Humandata.jpg" class="n2-ss-slide-background-image" data-blur="0" data-alt="Humandata" data-title="Humandata"></div></div><div class="n2-ss-layers-container n2-ow"><div class="n2-ss-layer n2-ow" style="padding:0px 0px 0px 0px;" data-desktopportraitpadding="0|*|0|*|0|*|0" data-sstype="slide" data-csstextalign="center" data-pm="default"></div></div></div><div data-slide-duration="0" data-id="154" data-title="IAR " data-haslink="1" style="cursor:pointer;" onclick="" data-href="http://www.iar.com" data-target="_blank" data-n2click="n2ss.openUrl(e);" data-n2middleclick="n2ss.openUrl(e, &#039;_blank&#039;);" class=" n2-ss-slide  n2-ss-slide-154 n2-ss-canvas n2-ow"><div class="n2-ss-slide-background n2-ow" data-mode="fit"><div data-hash="400621ed308681ef2d52cc5a1a27511e" data-desktop="//circuitcellar.com/wp-content/uploads/2019/10/IAR.jpg" class="n2-ss-slide-background-image" data-blur="0" data-alt="IAR Systems" data-title="IAR Systems"></div></div><div class="n2-ss-layers-container n2-ow"><div class="n2-ss-layer n2-ow" style="padding:0px 0px 0px 0px;" data-desktopportraitpadding="0|*|0|*|0|*|0" data-sstype="slide" data-csstextalign="center" data-pm="default"></div></div></div><div data-slide-duration="0" data-id="155" data-title="Measurement Computing" data-haslink="1" style="cursor:pointer;" onclick="" data-href="http://www.mccdaq.com/DAQ-HAT" data-target="_blank" data-n2click="n2ss.openUrl(e);" data-n2middleclick="n2ss.openUrl(e, &#039;_blank&#039;);" class=" n2-ss-slide  n2-ss-slide-155 n2-ss-canvas n2-ow"><div class="n2-ss-slide-background n2-ow" data-mode="fit"><div data-hash="659034809e264dcd36c89cae364d2743" data-desktop="//circuitcellar.com/wp-content/uploads/2019/10/MeasurementComputing.jpg" class="n2-ss-slide-background-image" data-blur="0" data-alt="Measurement Computing" data-title="Measurement Computing"></div></div><div class="n2-ss-layers-container n2-ow"><div class="n2-ss-layer n2-ow" style="padding:0px 0px 0px 0px;" data-desktopportraitpadding="0|*|0|*|0|*|0" data-sstype="slide" data-csstextalign="center" data-pm="default"></div></div></div><div data-slide-duration="0" data-id="156" data-title="Revenue Control Systems" data-haslink="1" style="cursor:pointer;" onclick="" data-href="http://rcspnp.com/" data-target="_blank" data-n2click="n2ss.openUrl(e);" data-n2middleclick="n2ss.openUrl(e, &#039;_blank&#039;);" class=" n2-ss-slide  n2-ss-slide-156 n2-ss-canvas n2-ow"><div class="n2-ss-slide-background n2-ow" data-mode="fit"><div data-hash="29979343166e5deb9a50db2831122c0b" data-desktop="//circuitcellar.com/wp-content/uploads/2019/10/RevenueControlSystems.jpg" class="n2-ss-slide-background-image" data-blur="0" data-alt="Revenue Control Systems" data-title="Revenue Control Systems"></div></div><div class="n2-ss-layers-container n2-ow"><div class="n2-ss-layer n2-ow" style="padding:0px 0px 0px 0px;" data-desktopportraitpadding="0|*|0|*|0|*|0" data-sstype="slide" data-csstextalign="center" data-pm="default"></div></div></div><div data-slide-duration="0" data-id="157" data-title="All Electronics" data-haslink="1" style="cursor:pointer;" onclick="" data-href="http://www.allelectronics.com" data-target="_blank" data-n2click="n2ss.openUrl(e);" data-n2middleclick="n2ss.openUrl(e, &#039;_blank&#039;);" class=" n2-ss-slide  n2-ss-slide-157 n2-ss-canvas n2-ow"><div class="n2-ss-slide-background n2-ow" data-mode="fit"><div data-hash="29979343166e5deb9a50db2831122c0b" data-desktop="//circuitcellar.com/wp-content/uploads/2019/10/RevenueControlSystems.jpg" class="n2-ss-slide-background-image" data-blur="0" data-alt="All Electronics" data-title="All Electronics"></div></div><div class="n2-ss-layers-container n2-ow"><div class="n2-ss-layer n2-ow" style="padding:0px 0px 0px 0px;" data-desktopportraitpadding="0|*|0|*|0|*|0" data-sstype="slide" data-csstextalign="center" data-pm="default"></div></div></div><div data-slide-duration="0" data-id="158" data-title="CCS" data-haslink="1" style="cursor:pointer;" onclick="" data-href="http://www.ccsinfo.com/cc1119" data-target="_blank" data-n2click="n2ss.openUrl(e);" data-n2middleclick="n2ss.openUrl(e, &#039;_blank&#039;);" class=" n2-ss-slide  n2-ss-slide-158 n2-ss-canvas n2-ow"><div class="n2-ss-slide-background n2-ow" data-mode="fit"><div data-hash="5bac2747ae76c422154e8d106cb30db4" data-desktop="//circuitcellar.com/wp-content/uploads/2019/10/CCS.jpg" class="n2-ss-slide-background-image" data-blur="0" data-alt="CCS" data-title="CCS"></div></div><div class="n2-ss-layers-container n2-ow"><div class="n2-ss-layer n2-ow" style="padding:0px 0px 0px 0px;" data-desktopportraitpadding="0|*|0|*|0|*|0" data-sstype="slide" data-csstextalign="center" data-pm="default"></div></div></div><div data-slide-duration="0" data-id="159" data-title="Siborg Systems" data-haslink="1" style="cursor:pointer;" onclick="" data-href="http://www.LCR-Reader.com" data-target="_blank" data-n2click="n2ss.openUrl(e);" data-n2middleclick="n2ss.openUrl(e, &#039;_blank&#039;);" class=" n2-ss-slide  n2-ss-slide-159 n2-ss-canvas n2-ow"><div class="n2-ss-slide-background n2-ow" data-mode="fit"><div data-hash="e2c5b8e0581824fd4c71f3ae1d516c58" data-desktop="//circuitcellar.com/wp-content/uploads/2019/10/Siborg.jpg" class="n2-ss-slide-background-image" data-blur="0" data-alt="Siborg Systems" data-title="Siborg Systems"></div></div><div class="n2-ss-layers-container n2-ow"><div class="n2-ss-layer n2-ow" style="padding:0px 0px 0px 0px;" data-desktopportraitpadding="0|*|0|*|0|*|0" data-sstype="slide" data-csstextalign="center" data-pm="default"></div></div></div><div data-slide-duration="0" data-id="160" data-title="Technologic Systems" data-haslink="1" style="cursor:pointer;" onclick="" data-href="http://www.embeddedARM.com" data-target="_blank" data-n2click="n2ss.openUrl(e);" data-n2middleclick="n2ss.openUrl(e, &#039;_blank&#039;);" class=" n2-ss-slide  n2-ss-slide-160 n2-ss-canvas n2-ow"><div class="n2-ss-slide-background n2-ow" data-mode="fit"><div data-hash="d15fd36b0ce9d262a323737cf2f68401" data-desktop="//circuitcellar.com/wp-content/uploads/2019/10/technologic-systems.jpg" class="n2-ss-slide-background-image" data-blur="0" data-alt="Technologic Systems" data-title="Technologic Systems"></div></div><div class="n2-ss-layers-container n2-ow"><div class="n2-ss-layer n2-ow" style="padding:0px 0px 0px 0px;" data-desktopportraitpadding="0|*|0|*|0|*|0" data-sstype="slide" data-csstextalign="center" data-pm="default"></div></div></div><div data-slide-duration="0" data-id="161" data-title="Versalogic" data-haslink="1" style="cursor:pointer;" onclick="" data-href="https://www.versalogic.com/" data-target="_blank" data-n2click="n2ss.openUrl(e);" data-n2middleclick="n2ss.openUrl(e, &#039;_blank&#039;);" class=" n2-ss-slide  n2-ss-slide-161 n2-ss-canvas n2-ow"><div class="n2-ss-slide-background n2-ow" data-mode="fit"><div data-hash="f786647b10978ce8e7f6ff2cd2653022" data-desktop="//circuitcellar.com/wp-content/uploads/2019/10/Versalogic.jpg" class="n2-ss-slide-background-image" data-blur="0" data-alt="Versalogic" data-title="Versalogic"></div></div><div class="n2-ss-layers-container n2-ow"><div class="n2-ss-layer n2-ow" style="padding:0px 0px 0px 0px;" data-desktopportraitpadding="0|*|0|*|0|*|0" data-sstype="slide" data-csstextalign="center" data-pm="default"></div></div></div></div></div></div><div data-ssleft="sliderWidth/2-bulletwidth/2" data-ssbottom="0+10" data-offset="10" class="n2-ss-widget  n2-flex n2-ss-control-bullet n2-ss-control-bullet-horizontal" style="position: absolute;"><div class=" nextend-bullet-bar n2-ow n2-bar-justify-content-center"></div></div></div></div><div id="n2-ss-2-spinner" style="display: none;"><div><div class="n2-ss-spinner-simple-white-container"><div class="n2-ss-spinner-simple-white"></div></div></div></div></div></div><div class="n2_clear"></div><div id="n2-ss-2-placeholder" style="position: relative;z-index:2;background-color:RGBA(0,0,0,0); background-color:RGBA(255,255,255,0);"><img style="width: 100%; max-width:10000px; display: block;opacity:0;margin:0px;" class="n2-ow jetpack-lazy-image" src="image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjAwIiA+PC9zdmc+" alt="Slider" data-lazy-src="https://image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjAwIiA+PC9zdmc+?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img style="width: 100%; max-width:10000px; display: block;opacity:0;margin:0px;" class="n2-ow" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI0MDAiIGhlaWdodD0iMjAwIiA+PC9zdmc+" alt="Slider" /></noscript></div></div></div></div></div><div class="bit-3"><div id="custom_html-8" class="widget_text widget widget_custom_html"><h4 class="widget-title">Upcoming Events</h4><div class="textwidget custom-html-widget"> <script type="text/javascript">if (document.avp_ready) { avp_multiple({ base: 'linuxgizmos.advertserve.com', type: 'banner', zid: 36, pid: 0, total: 2, renderer: 'strip', layout: 'vertical', margin: 0, padding: 0 }); }</script> </div></div></div><div class="bit-3"><style type="text/css">#current_issue a{ font-size:13px;}
		#current_issue ul{line-height:1; list-style:square;}
		#current_issue #issue_title{font-weight:600; font-size:16px;}
		#current_issue ul li{font-weight:bold list-style:circle;}</style><div id="current_issue-9" class="widget widget_current_issue"><h4 class="widget-title">Current Issue: August</h4><div class="featured"><div class="thumbnail"><a href="/inside-this-issue/"><img width="140" align="left" style="border-top:1px solid grey;border-right:1px solid grey;border-bottom:4px solid grey;border-left:4px solid grey; margin: 0px 12px 0px 0px" src="https://circuitcellar.com/wp-content/uploads/2020/07/CC-2020-08-Issue-361.jpg"></a></div><div class="links"><p><b>ICs for Automotive Designs</b></p> <b> <a href="/inside-this-issue/">&loz; Inside This Issue</a><br><br> <a target="_blank" href="https://simplecirc.com/subscriber_login/circuit-cellar">&loz; Digital Login</a><br> <a target="_blank" href="https://drive.google.com/drive/folders/1xeU29a9ZSZfGGtYFe625S9jttg_Ra2Oy">&loz; Article Code</a><br><br> <a target="_blank" href="/subscription-management/">&loz; Subscription Help</a><br> <a target="_blank" href="https://cc-webshop.com">&loz; Back Issue (PDFs)</a><br><br> <a target="_blank" href="/subscription/">&loz; Subscribe</a><br></div></div></div></div></div></div><div class="container-full site-info"><div class="container"><div class="vce-wrap-left"><p>Copyright &copy; 2020 KCK Media Corp.</p></div><div class="vce-wrap-right"><ul id="vce_footer_menu" class="bottom-nav-menu"><li id="menu-item-243644" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-243644"><a href="https://circuitcellar.com/privacy-statement-cookie-policy/">Privacy Statement-Cookie Policy</a></li></ul></div></div></div></footer></div></div> <a href="javascript:void(0)" id="back-top"><i class="fa fa-angle-up"></i></a> <!--googleoff: all--><div id="cookie-law-info-bar"><span>By using our site, you acknowledge that you have read and understand our <a href="/privacy-statement-cookie-policy/"> Cookie Policy and our Privacy Policy. </a><a role='button' tabindex='0' data-cli_action="accept" id="cookie_action_close_header" class="medium cli-plugin-button cli-plugin-main-button cookie_action_close_header cli_action_button" style="display:inline-block;  margin:5px; ">ACCEPT</a></span></div><div id="cookie-law-info-again" style="display:none;"><span id="cookie_hdr_showagain">Privacy & Cookies Policy</span></div><div class="cli-modal" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true"><div class="cli-modal-dialog" role="document"><div class="cli-modal-content cli-bar-popup"> <button type="button" class="cli-modal-close" id="cliModalClose"> <svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg> <span class="wt-cli-sr-only">Close</span> </button><div class="cli-modal-body"><div class="cli-container-fluid cli-tab-container"><div class="cli-row"><div class="cli-col-12 cli-align-items-stretch cli-px-0"><div class="cli-privacy-overview"><h4>Privacy Overview</h4><div class="cli-privacy-content"><div class="cli-privacy-content-text">This website uses cookies to improve your experience while you navigate through the website. Out of these cookies, the cookies that are categorized as necessary are stored on your browser as they are essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may have an effect on your browsing experience.</div></div> <a class="cli-privacy-readmore" data-readmore-text="Show more" data-readless-text="Show less"></a></div></div><div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container"><div class="cli-tab-section"><div class="cli-tab-header"> <a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab"> Necessary </a> <span class="cli-necessary-caption">Always Enabled</span></div><div class="cli-tab-content"><div class="cli-tab-pane cli-fade" data-id="necessary"><p>Necessary cookies are absolutely essential for the website to function properly. This category only includes cookies that ensures basic functionalities and security features of the website. These cookies do not store any personal information.</p></div></div></div></div></div></div></div></div></div></div><div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div><div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div> <script type="text/javascript">/* <![CDATA[ */
  cli_cookiebar_settings='{"animate_speed_hide":"500","animate_speed_show":"500","background":"#FFF","border":"#b1a6a6c2","border_on":false,"button_1_button_colour":"#000","button_1_button_hover":"#000000","button_1_link_colour":"#fff","button_1_as_button":true,"button_1_new_win":false,"button_2_button_colour":"#333","button_2_button_hover":"#292929","button_2_link_colour":"#444","button_2_as_button":false,"button_2_hidebar":false,"button_3_button_colour":"#000","button_3_button_hover":"#000000","button_3_link_colour":"#fff","button_3_as_button":true,"button_3_new_win":false,"button_4_button_colour":"#000","button_4_button_hover":"#000000","button_4_link_colour":"#62a329","button_4_as_button":false,"font_family":"inherit","header_fix":false,"notify_animate_hide":false,"notify_animate_show":false,"notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":false,"scroll_close_reload":false,"accept_close_reload":false,"reject_close_reload":false,"showagain_tab":false,"showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#000","show_once_yn":false,"show_once":"10000","logging_on":false,"as_popup":false,"popup_overlay":true,"bar_heading_text":"","cookie_bar_as":"banner","popup_showagain_position":"bottom-right","widget_position":"left"}';
  /* ]]> */</script> <!--googleon: all--><script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/photon/photon.min.js'></script> <script type='text/javascript' src='https://circuitcellar.com/wp-content/plugins/constant-contact-forms/assets/js/ctct-plugin-recaptcha-v2.min.js'></script> <script async="async" defer type='text/javascript' src='//www.google.com/recaptcha/api.js?onload=renderReCaptcha&#038;render=explicit&#038;ver=1.8.6'></script> <script type='text/javascript' src='https://circuitcellar.com/wp-content/plugins/constant-contact-forms/assets/js/ctct-plugin-frontend.min.js'></script> <script type='text/javascript' src='https://circuitcellar.com/wp-content/plugins/meks-flexible-shortcodes/js/main.js'></script> <script type='text/javascript'>/* <![CDATA[ */
var molongui_authorship = {"byline_prefix":"","byline_suffix":"","byline_separator":", ","byline_last_separator":" and ","byline_link_title":"View all posts by"};
/* ]]> */</script> <script type='text/javascript' src='https://circuitcellar.com/wp-content/plugins/molongui-authorship-pro/public/js/molongui-authorship-pro.11b6.min.js'></script> <script type='text/javascript' src='https://circuitcellar.com/wp-content/plugins/sg-cachepress/assets/js/lazysizes.min.js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/imagesloaded.min.js'></script> <script type='text/javascript'>/* <![CDATA[ */
var vce_js_settings = {"sticky_header":"1","sticky_header_offset":"400","sticky_header_logo":"","logo":"https:\/\/circuitcellar.com\/wp-content\/uploads\/2019\/08\/CC_logo.png","logo_retina":"","logo_mobile":"","logo_mobile_retina":"","rtl_mode":"0","ajax_url":"https:\/\/circuitcellar.com\/wp-admin\/admin-ajax.php","ajax_wpml_current_lang":null,"ajax_mega_menu":"1","mega_menu_slider":"1","mega_menu_subcats":"","lay_fa_grid_center":"","full_slider_autoplay":"","grid_slider_autoplay":"","grid_big_slider_autoplay":"","fa_big_opacity":{"1":"0.5","2":"0.7"},"top_bar_mobile":"1","top_bar_mobile_group":"1","top_bar_more_link":"More"};
/* ]]> */</script> <script type='text/javascript' src='https://circuitcellar.com/wp-content/themes/voice/assets/js/min.js'></script> <script type='text/javascript' src='https://circuitcellar.com/wp-content/plugins/meks-easy-social-share/assets/js/main.js'></script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/lazy-images/js/lazy-images.min.js'></script> <script type='text/javascript'>/* <![CDATA[ */
var ss_wp = {"ajax":"https:\/\/circuitcellar.com\/wp-admin\/admin-ajax.php","nonce":"8cd8ecc734"};
/* ]]> */</script> <script type='text/javascript' src='https://circuitcellar.com/wp-content/plugins/simple-sponsorships-premium/assets/dist/js/public.js'></script> <script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/wp-embed.min.js'></script> <script type='text/javascript' src='https://cdn.jsdelivr.net/npm/css-element-queries@1.2.2/src/ResizeSensor.min.js?ver=1.2.2'></script> <script type='text/javascript' src='https://cdn.jsdelivr.net/npm/css-element-queries@1.2.2/src/ElementQueries.min.js?ver=1.2.2'></script> <script type='text/javascript' src='https://stats.wp.com/e-202030.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7.1',blog:'173589359',post:'249311',tz:'-4',srv:'circuitcellar.com'} ]);
	_stq.push([ 'clickTrackerInit', '173589359', '249311' ]);</script> <script>( function( $ )  {

	$(document).ready( function() {
		$('.leaky-paywall-payment-button a').text('Register');
	});

})( jQuery );</script> </body></html>